summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am40
1 files changed, 23 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 18e28dd..fbf3de1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,8 +2,6 @@ lib_LTLIBRARIES = libtzplatform-config-@LIBTZPLATFORM_CONFIG_VERSION@.la
bin_PROGRAMS = tzplatform-get
-wrappersrcdir=$(shell pkg-config --variable=datadir tizen-platform-wrapper)
-
SRC_FROMWRAPPER_STATIC= \
static-api.c \
isadmin.h \
@@ -35,35 +33,43 @@ SRC_FROMWRAPPER_SHARED= \
SRC_FROMWRAPPER=$(SRC_FROMWRAPPER_SHARED) $(SRC_FROMWRAPPER_STATIC)
+SRC_TOOL = \
+ buffer.c \
+ foreign.c \
+ heap.c \
+ parser.c \
+ sha256sum.c \
+ toolbox.c
+
SRC_FROMTOOL= \
tzplatform_variables.h \
signup.inc \
hash.inc
-CFLAGS += -fPIC
+libtzplatform_config_@LIBTZPLATFORM_CONFIG_VERSION@_la_CFLAGS = -fPIC
-BUILT_SOURCES=$(SRC_FROMWRAPPER) $(SRC_FROMTOOL)
+BUILT_SOURCES=tzplatform-tool $(SRC_FROMTOOL)
-CLEANFILES=$(SRC_FROMWRAPPER) $(SRC_FROMTOOL)
+CLEANFILES=tzplatform-tool $(SRC_FROMTOOL)
libtzplatform_config_@LIBTZPLATFORM_CONFIG_VERSION@_la_SOURCES = \
$(SRC_FROMWRAPPER) \
$(SRC_FROMTOOL)
-tizen-platform.conf: /etc/tizen-platform.meta
- tzplatform-tool pretty $< >$@
+tzplatform-tool: $(SRC_TOOL)
+ $(CC) $^ -o $@
-$(SRC_FROMWRAPPER) tzplatform_get.c:
- cp $(wrappersrcdir)/tizen-platform-wrapper/$@ .
+tizen-platform.conf: /etc/tizen-platform.meta tzplatform-tool
+ ./tzplatform-tool pretty $< >$@
-tzplatform_variables.h: tizen-platform.conf
- tzplatform-tool h $< >$@
+tzplatform_variables.h: tizen-platform.conf tzplatform-tool
+ ./tzplatform-tool h $< >$@
-hash.inc: tizen-platform.conf
- tzplatform-tool c $< >$@
+hash.inc: tizen-platform.conf tzplatform-tool
+ ./tzplatform-tool c $< >$@
-signup.inc: tizen-platform.conf
- tzplatform-tool signup $< >$@
+signup.inc: tizen-platform.conf tzplatform-tool
+ ./tzplatform-tool signup $< >$@
libtzplatform_config_@LIBTZPLATFORM_CONFIG_VERSION@_la_LDFLAGS = -version-info $(LIBTZPLATFORM_CONFIG_SO_VERSION)
libtzplatform_config_@LIBTZPLATFORM_CONFIG_VERSION@_la_LDFLAGS += -Wl,--version-script=tzplatform_config.sym
@@ -75,8 +81,8 @@ nobase_libtzplatform_config_include_HEADERS = tzplatform_variables.h tzplatform_
dist_sysconf_DATA=tizen-platform.conf
-macros.tizen-platform: tizen-platform.conf
- tzplatform-tool rpm $< | grep -v TZ_USER_ > $@
+macros.tizen-platform: tizen-platform.conf tzplatform-tool
+ ./tzplatform-tool rpm $< | grep -v TZ_USER_ > $@
tzplatform_config_sysconfdir= $(sysconfdir)/rpm
dist_tzplatform_config_sysconf_DATA=macros.tizen-platform