summaryrefslogtreecommitdiff
path: root/src/plugins/ds-public/vcard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/ds-public/vcard/CMakeLists.txt')
-rwxr-xr-xsrc/plugins/ds-public/vcard/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/plugins/ds-public/vcard/CMakeLists.txt b/src/plugins/ds-public/vcard/CMakeLists.txt
new file mode 100755
index 0000000..bdd1871
--- /dev/null
+++ b/src/plugins/ds-public/vcard/CMakeLists.txt
@@ -0,0 +1,42 @@
+
+#############################################
+#
+# Step 1. Set Variable and Build Dependency
+#
+
+# set plguin name
+SET(PLUGIN_NAME "dc-vcard")
+
+# set a name for the entire project
+PROJECT(plugin-${PLUGIN_NAME})
+
+# checks for build dependency modules : a pkg-config module for CMake
+INCLUDE(FindPkgConfig)
+pkg_check_modules(${PLUGIN_NAME} REQUIRED
+ contacts-service2
+ sync-agent
+ dlog
+ libwbxml2)
+
+#############################################
+#
+# Step 2. Set Compile Environment
+#
+
+# set extra cflags from build dependency
+SET(PLUGIN_CFLAGS "${dc-vcard_CFLAGS}")
+
+#############################################
+#
+# Step 3. Set Link Environment
+#
+
+# link a target to given libraries from pkg-config.
+SET(PLUGIN_LDFLAGS "${dc-vcard_LDFLAGS}")
+
+#############################################
+#
+# Step 4. Install packages
+#
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/../../CMakeLists.sub) \ No newline at end of file