summaryrefslogtreecommitdiff
path: root/packaging/oma-ds-agent.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/oma-ds-agent.spec')
-rwxr-xr-xpackaging/oma-ds-agent.spec29
1 files changed, 18 insertions, 11 deletions
diff --git a/packaging/oma-ds-agent.spec b/packaging/oma-ds-agent.spec
index 1782263..f477726 100755
--- a/packaging/oma-ds-agent.spec
+++ b/packaging/oma-ds-agent.spec
@@ -1,6 +1,6 @@
Name: oma-ds-agent
Summary: oma-ds-agent daemon for data sync
-Version: 0.1.6
+Version: 0.1.62
Release: 1
Group: TO_BE/FILLED_IN
License: Apache License, Version 2.0
@@ -12,7 +12,6 @@ BuildRequires: pkgconfig(libsoup-2.4)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(sync-agent)
BuildRequires: pkgconfig(vconf)
-BuildRequires: pkgconfig(libwbxml2)
BuildRequires: pkgconfig(dbus-glib-1)
BuildRequires: pkgconfig(check)
BuildRequires: pkgconfig(memo)
@@ -21,6 +20,7 @@ BuildRequires: pkgconfig(dlog)
BuildRequires: pkgconfig(aul)
BuildRequires: expat-devel
BuildRequires: cmake
+Requires: sys-assert
%description
@@ -45,6 +45,14 @@ make %{?jobs:-j%jobs}
%install
rm -rf %{buildroot}
+
+if [ ! -d %{buildroot}/opt/dbspace ]
+then
+ mkdir -p %{buildroot}/opt/dbspace
+fi
+
+sqlite3 %{buildroot}/opt/dbspace/.omasyncagent.db "PRAGMA journal_mode = PERSIST; create table a(a); drop table a;" > /dev/null
+
%make_install
@@ -66,18 +74,14 @@ then
mkdir /etc/rc.d/rc5.d
fi
+if [ ! -f /etc/rc.d/rc3.d/S91oma-ds-agent ]
+then
ln -s /etc/init.d/oma-ds /etc/rc.d/rc3.d/S91oma-ds-agent
-ln -s /etc/init.d/oma-ds /etc/rc.d/rc5.d/S91oma-ds-agent
-
-sqlite3 /opt/dbspace/.omasyncagent.db "PRAGMA journal_mode = PERSIST; create table a(a); drop table a;" > /dev/null
-
-chmod 600 /opt/dbspace/.omasyncagent.db
-chmod 600 /opt/dbspace/.omasyncagent.db-journal
+fi
-if [ -f /usr/lib/rpm-plugins/msm.so ]
+if [ ! -f /etc/rc.d/rc5.d/S91oma-ds-agent ]
then
- chsmack -a oma-ds-agent::db /opt/dbspace/.omasyncagent.db
- chsmack -a oma-ds-agent::db /opt/dbspace/.omasyncagent.db-journal
+ ln -s /etc/init.d/oma-ds /etc/rc.d/rc5.d/S91oma-ds-agent
fi
#/etc/init.d/oma-ds start
@@ -101,6 +105,9 @@ rm -rf /usr/share/oma-ds-cfg
%files
+%attr(600,root,root) /opt/dbspace/.omasyncagent.db
+%attr(600,root,root) /opt/dbspace/.omasyncagent.db-journal
+
%manifest oma-ds-agent.manifest
%defattr(-,root,root,-)
/usr/share/dbus-1/services/*