summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog47
-rwxr-xr-xdebian/control22
-rw-r--r--debian/control.slp8
-rw-r--r--debian/postinst45
-rwxr-xr-xdebian/rules104
5 files changed, 226 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d9f499e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,47 @@
+oma-ds-agent (0.1.6) unstable; urgency=low
+
+ * 1. license file update.
+ * Git: framework/system/oma-ds-agent
+ * Tag: oma-ds-agent_0.1.6
+
+ -- Juhaki Park <juhaki.park@samsung.com> Mon, 21 Jan 2013 22:09:10 +0900
+
+oma-ds-agent (0.1.5) unstable; urgency=low
+
+ * 1. Revised for version release
+ * Git: framework/system/oma-ds-agent
+ * Tag: oma-ds-agent_0.1.5
+
+ -- Juhaki Park <juhaki.park@samsung.com> Thu, 10 Jan 2013 10:06:10 +0900
+
+oma-ds-agent (0.1.4) unstable; urgency=low
+
+ * 1. Revised for version release
+ * Git: framework/system/oma-ds-agent
+ * Tag: oma-ds-agent_0.1.4
+
+ -- WooJin Yun <suhoangel9@samsung.com> Wed, 09 Jan 2013 19:42:10 +0900
+
+oma-ds-agent (0.1.3) unstable; urgency=low
+
+ * 1. Fixes for Prevent defects
+ * Git: framework/system/oma-ds-agent
+ * Tag: oma-ds-agent_0.1.3
+
+ -- sanghyuk.ko <sanghyuk.ko@samsung.com> Wed, 09 Jan 2013 17:31:34 +0900
+
+oma-ds-agent (0.1.2) unstable; urgency=low
+
+ * 1. Internal: build error & dependency patch
+ * Git: framework/system/oma-ds-agent
+ * Tag: oma-ds-agent_0.1.2
+
+ -- WooJin Yun <suhoangel9@samsung.com> Fri, 28 Dec 2012 22:47:52 +0900
+
+oma-ds-agent (0.1.1) unstable; urgency=low
+
+ * Initial Update
+ * Git: framework/system/oma-ds-agent
+ * Tag: oma-ds-agent_0.1.1
+
+ -- WooJin Yun <suhoangel9@samsung.com> Wed, 01 Feb 2012 10:30:16 +0900
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..5166e62
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,22 @@
+Source: oma-ds-agent
+Section: embedded
+Priority: optional
+Maintainer: WooJin Yun <suhoangel9@samsung.com>, Joohark Park <juhaki.park@samsung.com>, Junhyuk Lee <junhyuk7.lee@samsung.com>
+Uploaders: Joohark Park <juhaki.park@samsung.com>, Junhyuk Lee <junhyuk7.lee@samsung.com>
+Build-Depends: debhelper (>= 5), libglib2.0-dev, sqlite3, libsoup2.4-dev, libsqlite3-dev, check, libvconf-dev, libexpat1-dev, libsync-agent-framework-dev, libwbxml2-dev
+Standards-Version: 0.1.1
+
+Package: oma-ds-agent
+Section: embedded
+Architecture: any
+Priority: optional
+Depends: ${shlibs:Depends}, ${misc:Depends},
+Description: OMA Data Synchronization service module
+
+Package: oma-ds-agent-dbg
+Section: debug
+Architecture: any
+Priority: optional
+Depends: ${shlibs:Depends}, ${misc:Depends}, oma-ds-agent (= ${Source-Version})
+Description: OMA Data Synchronization service module (unstripped)
+
diff --git a/debian/control.slp b/debian/control.slp
new file mode 100644
index 0000000..20474e7
--- /dev/null
+++ b/debian/control.slp
@@ -0,0 +1,8 @@
+#Mon Nov 08 05:13:18 KST 2010
+Privileges=
+AppInstallPath=/usr
+UserUninstall=yes
+IdealScreen=480x800,46x71
+Version=1.0.0
+
+
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..711fa30
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,45 @@
+#!/bin/sh
+
+echo ""
+echo ""
+echo "*********************************************************************************"
+echo " post install script run..."
+echo "*********************************************************************************"
+echo "executing oma agent unit test binary."
+
+OMA_TEST_BIN="/usr/bin/oma-test"
+if [ ! -e "$OMA_TEST_BIN" ]
+then
+ echo " oma-agent test binary missing. (check debian package is in release mode)"
+else
+
+ echo ""
+ echo ""
+ echo "*********************************************************************************"
+ echo " oma agent unit test run..."
+ echo "*********************************************************************************"
+ echo ""
+ $OMA_TEST_BIN
+fi
+echo "create oma-ds directory"
+if [ ! -d /opt/data/oma-ds ]
+then
+ mkdir /opt/data/oma-ds
+fi
+
+echo "deleting framework db files"
+if [ -d /usr/share/sync-agent-framework ]
+then
+ rm -rf /usr/share/sync-agent-framework
+fi
+
+echo "deleting db files"
+if [ -f /opt/dbspace/.omasyncagent.db ]
+then
+ rm -rf /opt/dbspace/.omasyncagent.db
+fi
+
+if [ -f /opt/dbspace/.omasyncagent.db-journal ]
+then
+ rm -rf /opt/dbspace/.omasyncagent.db-journal
+fi
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a28c17d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,104 @@
+#!/usr/bin/make -f
+
+## DO NOT MODIFY THIS AREA : BEGIN
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# $(PKGDIR) is a package build directory to create a final .deb package .
+include debian/control.slp
+
+PKGDIR = debian/PKG
+ifneq (,$(filter ide,$(DEB_BUILD_OPTIONS)))
+DESTDIR = .
+else
+DESTDIR = ..
+endif
+CONTROLFILE = debian/control.slp
+CONTROLFILE_SRC = debian/control
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+build: pre-build configure
+ # Add here commands to compile the package.
+ $(MAKE)
+
+configure:
+ cmake . -DCMAKE_INSTALL_PREFIX=${AppInstallPath} -DCMAKE_PROJECT=${Source}
+ rm -rf CMakeFiles/CompilerIdC*
+# sed 's/^Package:.*$$/Package: $(Package)/' $(CONTROLFILE_SRC) > $(CONTROLFILE_SRC).tmp ; mv -f $(CONTROLFILE_SRC).tmp $(CONTROLFILE_SRC)
+
+clean:
+ # Add here commands to clean up before the build process.
+ # debian clean
+ -$(MAKE) clean
+
+ -find . -name "CMakeFiles" -exec rm -rf {} \;
+ -find . -name "CMakeCache.txt" -exec rm -rf {} \;
+ -find . -name "Makefile" -exec rm -rf {} \;
+ -find . -name "cmake_install.cmake" -exec rm -rf {} \;
+ -find . -name "install_manifest.txt" -exec rm -rf {} \;
+ -find . -name "*.pc" -exec rm -rf {} \;
+ -find . -name "*.so" -exec rm -rf {} \;
+
+ -rm -rf ./oma-ds-agent
+ -rm -rf ./oma-test
+
+ -rm -rf $(PKGDIR)
+
+ dh_clean
+
+install: build pre-install
+ rm -rf $(PKGDIR)
+ mkdir $(PKGDIR)
+
+ # Add here commands to install the package into $(PKGDIR).
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+ mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/init.d
+ install -c $(CURDIR)/syncmld_mgr $(CURDIR)/debian/tmp/etc/rc.d/init.d
+
+ mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/rc3.d
+ ln -s ../init.d/syncmld_mgr $(CURDIR)/debian/tmp/etc/rc.d/rc3.d/S91oma-ds-agent
+
+ mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/rc5.d
+ ln -s ../init.d/syncmld_mgr $(CURDIR)/debian/tmp/etc/rc.d/rc5.d/S91oma-ds-agent
+
+# Build architecture-dependent files here.
+binary: install pre-binary
+ dh_testdir
+ dh_testroot
+ #dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+ dh_link
+ dh_strip --dbg-package=oma-ds-agent
+ dh_compress
+ dh_fixperms
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+.PHONY: build clean install binary
+## DO NOT MODIFY THIS AREA : END
+
+## DO NOT MODIFY OR DELETE TARGET.
+pre-build:
+ # Add here commands to execute before the build process.
+
+pre-install:
+ # Add here commands to execute before installing the binaries into $(PKGDIR).
+
+pre-binary:
+ # Add here commands to execute before creating a package.
+