summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules104
1 files changed, 0 insertions, 104 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index a28c17d..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/usr/bin/make -f
-
-## DO NOT MODIFY THIS AREA : BEGIN
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# $(PKGDIR) is a package build directory to create a final .deb package .
-include debian/control.slp
-
-PKGDIR = debian/PKG
-ifneq (,$(filter ide,$(DEB_BUILD_OPTIONS)))
-DESTDIR = .
-else
-DESTDIR = ..
-endif
-CONTROLFILE = debian/control.slp
-CONTROLFILE_SRC = debian/control
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-build: pre-build configure
- # Add here commands to compile the package.
- $(MAKE)
-
-configure:
- cmake . -DCMAKE_INSTALL_PREFIX=${AppInstallPath} -DCMAKE_PROJECT=${Source}
- rm -rf CMakeFiles/CompilerIdC*
-# sed 's/^Package:.*$$/Package: $(Package)/' $(CONTROLFILE_SRC) > $(CONTROLFILE_SRC).tmp ; mv -f $(CONTROLFILE_SRC).tmp $(CONTROLFILE_SRC)
-
-clean:
- # Add here commands to clean up before the build process.
- # debian clean
- -$(MAKE) clean
-
- -find . -name "CMakeFiles" -exec rm -rf {} \;
- -find . -name "CMakeCache.txt" -exec rm -rf {} \;
- -find . -name "Makefile" -exec rm -rf {} \;
- -find . -name "cmake_install.cmake" -exec rm -rf {} \;
- -find . -name "install_manifest.txt" -exec rm -rf {} \;
- -find . -name "*.pc" -exec rm -rf {} \;
- -find . -name "*.so" -exec rm -rf {} \;
-
- -rm -rf ./oma-ds-agent
- -rm -rf ./oma-test
-
- -rm -rf $(PKGDIR)
-
- dh_clean
-
-install: build pre-install
- rm -rf $(PKGDIR)
- mkdir $(PKGDIR)
-
- # Add here commands to install the package into $(PKGDIR).
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
-
- mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/init.d
- install -c $(CURDIR)/syncmld_mgr $(CURDIR)/debian/tmp/etc/rc.d/init.d
-
- mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/rc3.d
- ln -s ../init.d/syncmld_mgr $(CURDIR)/debian/tmp/etc/rc.d/rc3.d/S91oma-ds-agent
-
- mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/rc5.d
- ln -s ../init.d/syncmld_mgr $(CURDIR)/debian/tmp/etc/rc.d/rc5.d/S91oma-ds-agent
-
-# Build architecture-dependent files here.
-binary: install pre-binary
- dh_testdir
- dh_testroot
- #dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_install --sourcedir=debian/tmp
- dh_link
- dh_strip --dbg-package=oma-ds-agent
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-.PHONY: build clean install binary
-## DO NOT MODIFY THIS AREA : END
-
-## DO NOT MODIFY OR DELETE TARGET.
-pre-build:
- # Add here commands to execute before the build process.
-
-pre-install:
- # Add here commands to execute before installing the binaries into $(PKGDIR).
-
-pre-binary:
- # Add here commands to execute before creating a package.
-