summaryrefslogtreecommitdiff
path: root/src/agent/CMakeLists.txt
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2013-08-21 13:18:07 +0800
committerChengwei Yang <chengwei.yang@intel.com>2013-08-21 13:18:36 +0800
commit047d0849293d4289282b1e1fe34c35eb71fa5cb5 (patch)
treeffb8d54e55ffb5537c4399e60b12904cd67d07db /src/agent/CMakeLists.txt
parent904a5884eb0d707d5a1c91e05b9e11708ae62905 (diff)
downloadoma-ds-agent-047d0849293d4289282b1e1fe34c35eb71fa5cb5.tar.gz
oma-ds-agent-047d0849293d4289282b1e1fe34c35eb71fa5cb5.tar.bz2
oma-ds-agent-047d0849293d4289282b1e1fe34c35eb71fa5cb5.zip
Remove sysvinit script and fix systemd unit
Sysvinit script is obsolete since tizen 2.1, so it's time to remove it. Meanwhile, there was a minor bug when migrate from sysvinit to systemd, so fix it. Change-Id: If34315c539429e0802050756cc343b69d2c77753 Signed-off-by: Chengwei Yang <chengwei.yang@intel.com>
Diffstat (limited to 'src/agent/CMakeLists.txt')
-rwxr-xr-xsrc/agent/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/agent/CMakeLists.txt b/src/agent/CMakeLists.txt
index 0d99c9e..ee1ea32 100755
--- a/src/agent/CMakeLists.txt
+++ b/src/agent/CMakeLists.txt
@@ -79,7 +79,3 @@ INSTALL(FILES ${CMAKE_SOURCE_DIR}/com.samsung.omadsagent.conf DESTINATION /etc/d
INSTALL(FILES ${CMAKE_SOURCE_DIR}/oma-ds-agent.service DESTINATION /usr/lib/systemd/system)
INSTALL(CODE "FILE(MAKE_DIRECTORY \$ENV{DESTDIR}/usr/lib/systemd/system/graphical.target.wants)")
INSTALL(CODE "EXECUTE_PROCESS(COMMAND ln -sf ../oma-ds-agent.service . WORKING_DIRECTORY \$ENV{DESTDIR}/usr/lib/systemd/system/graphical.target.wants)")
-
-# install booting script file
-INSTALL(PROGRAMS ${CMAKE_SOURCE_DIR}/${PROJECT_NAME} DESTINATION /etc/init.d/)
-