summaryrefslogtreecommitdiff
path: root/packaging/oma-ds-agent.spec
diff options
context:
space:
mode:
authorJinkun Jang <jinkun.jang@samsung.com>2013-03-13 01:51:48 +0900
committerJinkun Jang <jinkun.jang@samsung.com>2013-03-13 01:51:48 +0900
commitd6aa47559c38d7e20d6d6a7a3671fa48ed58b9eb (patch)
tree5fbc758662a7866e32ec1adcfd9149c71987549e /packaging/oma-ds-agent.spec
parent8fe192a924f295972402d46141e39b86241a1441 (diff)
downloadoma-ds-agent-d6aa47559c38d7e20d6d6a7a3671fa48ed58b9eb.tar.gz
oma-ds-agent-d6aa47559c38d7e20d6d6a7a3671fa48ed58b9eb.tar.bz2
oma-ds-agent-d6aa47559c38d7e20d6d6a7a3671fa48ed58b9eb.zip
Tizen 2.1 base
Diffstat (limited to 'packaging/oma-ds-agent.spec')
-rwxr-xr-xpackaging/oma-ds-agent.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/packaging/oma-ds-agent.spec b/packaging/oma-ds-agent.spec
new file mode 100755
index 0000000..1782263
--- /dev/null
+++ b/packaging/oma-ds-agent.spec
@@ -0,0 +1,117 @@
+Name: oma-ds-agent
+Summary: oma-ds-agent daemon for data sync
+Version: 0.1.6
+Release: 1
+Group: TO_BE/FILLED_IN
+License: Apache License, Version 2.0
+Source0: %{name}-%{version}.tar.gz
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(libsoup-2.4)
+BuildRequires: pkgconfig(sqlite3)
+BuildRequires: pkgconfig(sync-agent)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(libwbxml2)
+BuildRequires: pkgconfig(dbus-glib-1)
+BuildRequires: pkgconfig(check)
+BuildRequires: pkgconfig(memo)
+BuildRequires: pkgconfig(contacts-service2)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(aul)
+BuildRequires: expat-devel
+BuildRequires: cmake
+
+
+%description
+oma-ds-agent daemon (development headers)
+
+%package -n ds-public-plugins
+Summary: DS Public Plugins
+Group: TO_BE_FILLED
+
+%description -n ds-public-plugins
+ds public plugins for sync-agent
+
+
+%prep
+%setup -q
+
+
+%build
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+make %{?jobs:-j%jobs}
+
+
+%install
+rm -rf %{buildroot}
+%make_install
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+if [ ! -d /opt/dbspace ]
+then
+ mkdir /opt/dbspace
+fi
+if [ ! -d /etc/rc.d/rc3.d ]
+then
+ mkdir /etc/rc.d/rc3.d
+fi
+if [ ! -d /etc/rc.d/rc5.d ]
+then
+ mkdir /etc/rc.d/rc5.d
+fi
+
+ln -s /etc/init.d/oma-ds /etc/rc.d/rc3.d/S91oma-ds-agent
+ln -s /etc/init.d/oma-ds /etc/rc.d/rc5.d/S91oma-ds-agent
+
+sqlite3 /opt/dbspace/.omasyncagent.db "PRAGMA journal_mode = PERSIST; create table a(a); drop table a;" > /dev/null
+
+chmod 600 /opt/dbspace/.omasyncagent.db
+chmod 600 /opt/dbspace/.omasyncagent.db-journal
+
+if [ -f /usr/lib/rpm-plugins/msm.so ]
+then
+ chsmack -a oma-ds-agent::db /opt/dbspace/.omasyncagent.db
+ chsmack -a oma-ds-agent::db /opt/dbspace/.omasyncagent.db-journal
+fi
+
+#/etc/init.d/oma-ds start
+
+
+%preun
+/etc/init.d/oma-ds stop
+
+
+%postun
+
+rm -f /tmp/agent_fw_event_omads*
+rm -f /tmp/agent_fw_noti_reply_omads*
+
+rm -f /etc/rc.d/rc3.d/S91oma-ds-agent
+rm -f /etc/rc.d/rc5.d/S91oma-ds-agent
+
+rm -f /opt/dbspace/.omasyncagent.db /opt/dbspace/.omasyncagent.db-journal
+
+rm -rf /usr/share/oma-ds-cfg
+
+
+%files
+%manifest oma-ds-agent.manifest
+%defattr(-,root,root,-)
+/usr/share/dbus-1/services/*
+/usr/bin/oma-ds-agent
+
+/usr/share/oma-ds-cfg/*
+
+%defattr(700,root,root)
+/etc/init.d/oma-ds
+
+%files -n ds-public-plugins
+%manifest ds-public-plugins.manifest
+%defattr(-,root,root,-)
+/usr/lib/sync-agent/ds-public/*