summaryrefslogtreecommitdiff
path: root/src/plugins/dm-private/slp-device-dm/CMakeLists.txt
diff options
context:
space:
mode:
authorHyungKyu Song <hk76.song@samsung.com>2013-02-16 00:55:29 +0900
committerHyungKyu Song <hk76.song@samsung.com>2013-02-16 00:55:29 +0900
commit4043c48868b1eafa7701ac19b4f93bc90ce79c99 (patch)
tree6f3bda67c8725cb999c8fe93c4c3846c83074be8 /src/plugins/dm-private/slp-device-dm/CMakeLists.txt
parent2505051c83d63da1cac1e0ca958574cf98e164d9 (diff)
downloadoma-dm-agent-4043c48868b1eafa7701ac19b4f93bc90ce79c99.tar.gz
oma-dm-agent-4043c48868b1eafa7701ac19b4f93bc90ce79c99.tar.bz2
oma-dm-agent-4043c48868b1eafa7701ac19b4f93bc90ce79c99.zip
Diffstat (limited to 'src/plugins/dm-private/slp-device-dm/CMakeLists.txt')
-rwxr-xr-xsrc/plugins/dm-private/slp-device-dm/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/plugins/dm-private/slp-device-dm/CMakeLists.txt b/src/plugins/dm-private/slp-device-dm/CMakeLists.txt
new file mode 100755
index 0000000..0f8050f
--- /dev/null
+++ b/src/plugins/dm-private/slp-device-dm/CMakeLists.txt
@@ -0,0 +1,48 @@
+
+#############################################
+#
+# Step 1. Set Variable and Build Dependency
+#
+
+# set plguin name
+SET(PLUGIN_NAME "di-slp-device-dm")
+
+# set a name for the entire project
+PROJECT(plugin-${PLUGIN_NAME})
+
+# checks for build dependency modules : a pkg-config module for CMake
+INCLUDE(FindPkgConfig)
+pkg_check_modules(${PLUGIN_NAME} REQUIRED
+ sync-agent
+ glib-2.0
+ vconf
+ tapi
+ pmapi
+ dlog
+ libwbxml2
+ )
+
+#############################################
+#
+# Step 2. Set Compile Environment
+#
+
+# set extra cflags from build dependency
+SET(PLUGIN_CFLAGS "${di-slp-device-dm_CFLAGS}")
+
+#############################################
+#
+# Step 3. Set Link Environment
+#
+
+# link a target to given libraries from pkg-config.
+SET(PLUGIN_LDFLAGS "${di-slp-device-dm_LDFLAGS}")
+
+#############################################
+#
+# Step 4. Install packages
+#
+
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/include/plugin_slp_device_dm.h DESTINATION include/sync-agent/plugin/)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/../../CMakeLists.sub)