summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..eb06296
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,24 @@
+ACLOCAL_AMFLAGS = -I m4
+
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-gtk-doc
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libtlm-nfc.pc
+
+if HAVE_CHECK
+SUBDIRS = src docs test
+else
+SUBDIRS = src docs
+endif
+
+valgrind:
+ cd test; make valgrind
+
+lcov: check
+ @rm -rf lcov-report
+ @lcov -c --directory src/ --output-file lcov.output
+ @genhtml lcov.output --output-directory lcov-report
+ @rm lcov.output
+ @echo "Coverage report is in file://$(abs_srcdir)/lcov-report/index.html"
+