summaryrefslogtreecommitdiff
path: root/packaging/libsystem.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/libsystem.spec')
-rw-r--r--packaging/libsystem.spec18
1 files changed, 16 insertions, 2 deletions
diff --git a/packaging/libsystem.spec b/packaging/libsystem.spec
index a15de97..79d7ea0 100644
--- a/packaging/libsystem.spec
+++ b/packaging/libsystem.spec
@@ -5,7 +5,9 @@ Release: 2%{?release_flags}
License: Apache-2.0
Group: System/Libraries
Source: %{name}-%{version}.tar.gz
+%if 0%{?_with_tizen}
Source1001: %{name}.manifest
+%endif
BuildRequires: autoconf
BuildRequires: automake
@@ -54,7 +56,9 @@ Development header files for systemd util.
%setup -q
%build
+%if 0%{?_with_tizen}
cp %{SOURCE1001} .
+%endif
%if 0%{?debug_enable}
export CFLAGS=$(echo $CFLAGS | sed -e 's/^-g / /g' | sed -e 's/ -g / /g')
@@ -63,14 +67,16 @@ export CFLAGS=$(echo $CFLAGS | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2 / /g')
export CFLAGS="-O0 -g $CFLAGS"
%endif
-%autogen
-%reconfigure
+./autogen.sh
+%configure
make %{?_smp_mflags}
%install
%make_install
+rm -f %{buildroot}%{_libdir}/*.la
+
# make sure debugsources.list exist, it used by rpm macro in %file
# section.
touch debugsources.list
@@ -91,12 +97,16 @@ make check
%files
%defattr(-,root,root,-)
+%if 0%{?_with_tizen}
%manifest %{name}.manifest
+%endif
%{_libdir}/libsystem.so.*
%files devel
%defattr(-,root,root,-)
+%if 0%{?_with_tizen}
%manifest %{name}.manifest
+%endif
%{_libdir}/libsystem.so
%{_includedir}/libsystem/config-parser.h
%{_includedir}/libsystem/dbus-util.h
@@ -106,12 +116,16 @@ make check
%files -n libsystem-sd
%defattr(-,root,root,-)
+%if 0%{?_with_tizen}
%manifest %{name}.manifest
+%endif
%{_libdir}/libsystem-sd.so.*
%files -n libsystem-sd-devel
%defattr(-,root,root,-)
+%if 0%{?_with_tizen}
%manifest %{name}.manifest
+%endif
%{_libdir}/libsystem-sd.so
%{_includedir}/libsystem-sd/systemd.h
%{_libdir}/pkgconfig/libsystem-sd.pc