summaryrefslogtreecommitdiff
path: root/packaging/libsystem.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/libsystem.spec')
-rw-r--r--packaging/libsystem.spec26
1 files changed, 20 insertions, 6 deletions
diff --git a/packaging/libsystem.spec b/packaging/libsystem.spec
index 7172d32..9d7051a 100644
--- a/packaging/libsystem.spec
+++ b/packaging/libsystem.spec
@@ -2,8 +2,8 @@ Name: libsystem
Summary: System Libraries
Version: 3.6
Release: 5
-License: Apache License v2
-Group: System/Base
+License: Apache-2.0
+Group: System/Libraries
Source: %{name}-%{version}.tar.gz
BuildRequires: autoconf
@@ -15,27 +15,30 @@ BuildRequires: pkgconfig(gio-2.0)
Requires: /bin/cp
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
%description
System libraries.
%package devel
Summary: Development header files for System Libraries
-License: Apache License v2
+License: Apache-2.0
Requires: pkgconfig(glib-2.0)
%description devel
Development headers and auxiliary files.
%package -n libsystem-sd
-Summary: systemd utility libraries
-License: Apache License v2
+Summary: Utility libraries for systemd
+License: Apache-2.0
%description -n libsystem-sd
systemd utility libraries.
%package -n libsystem-sd-devel
Summary: Development header files for systemd util
-License: Apache License v2
+License: Apache-2.0
Requires: pkgconfig(gio-2.0)
Requires: pkgconfig(dbus-1)
Requires: pkgconfig(libsystem)
@@ -67,6 +70,17 @@ make %{?_smp_mflags}
# Remove local archives
rm -f %{buildroot}%{_libdir}/*.la
+
+%post
+/sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%post -n libsystem-sd
+/sbin/ldconfig
+
+%postun -n libsystem-sd -p /sbin/ldconfig
+
%files
%defattr(-,root,root,-)
%{_libdir}/libsystem.so.*