summaryrefslogtreecommitdiff
path: root/packaging/libsystem.spec
diff options
context:
space:
mode:
authorWaLyong Cho <walyong.cho@samsung.com>2016-10-17 14:21:53 +0900
committerWaLyong Cho <walyong.cho@samsung.com>2016-10-17 14:22:05 +0900
commitbf6b02d15c986496b697131a68f3f99c6dcf1e70 (patch)
treee2f9fc203521135e04ccca966837ae4cad7585c7 /packaging/libsystem.spec
parent7928edd9b8dfd3501154bd70decdcefa1c275b43 (diff)
parent2836b189c0b82d8baacadadff7517d13ba03eacc (diff)
downloadlibsystem-bf6b02d15c986496b697131a68f3f99c6dcf1e70.tar.gz
libsystem-bf6b02d15c986496b697131a68f3f99c6dcf1e70.tar.bz2
libsystem-bf6b02d15c986496b697131a68f3f99c6dcf1e70.zip
release: 4.0-0
[Model] Common [BinType] AP [Customer] N/A [Issue] N/A [Request] N/A [Occurrence Version] N/A [Problem] release: 4.0-0 [Cause & Measure] N/A [Checking Method] N/A [Team] SystemFW [Developer] WaLyong Cho [Solution company] Samsung [Change Type] N/A * devel/systemfw/master: release: 4.0-0 rpm: spec: modify rpm spec properly test: add test-truncate_nl make: add tests gitignore: update git ignores remove empty files initial files upload Change-Id: Iff40ea8c67918bc95e4c91be572299939477ea05 Signed-off-by: WaLyong Cho <walyong.cho@samsung.com>
Diffstat (limited to 'packaging/libsystem.spec')
-rw-r--r--packaging/libsystem.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/packaging/libsystem.spec b/packaging/libsystem.spec
new file mode 100644
index 0000000..a19c75a
--- /dev/null
+++ b/packaging/libsystem.spec
@@ -0,0 +1,105 @@
+Name: libsystem
+Summary: System Libraries
+Version: 4.0
+Release: 0
+License: Apache-2.0
+Group: System/Libraries
+Source: %{name}-%{version}.tar.gz
+
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+BuildRequires: pkgconfig(dbus-1)
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gio-2.0)
+
+Requires: /bin/cp
+
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description
+System libraries.
+
+%package devel
+Summary: Development header files for System Libraries
+License: Apache-2.0
+Requires: pkgconfig(glib-2.0)
+
+%description devel
+Development headers and auxiliary files.
+
+%package -n libsystem-sd
+Summary: Utility libraries for systemd
+License: Apache-2.0
+
+%description -n libsystem-sd
+systemd utility libraries.
+
+%package -n libsystem-sd-devel
+Summary: Development header files for systemd util
+License: Apache-2.0
+Requires: pkgconfig(gio-2.0)
+Requires: pkgconfig(dbus-1)
+Requires: pkgconfig(libsystem)
+
+%description -n libsystem-sd-devel
+Development header files for systemd util.
+
+%prep
+%setup -q
+
+%build
+%if 0%{?debug_enable}
+export CFLAGS=$(echo $CFLAGS | sed -e 's/^-g / /g' | sed -e 's/ -g / /g')
+export CFLAGS=$(echo $CFLAGS | sed -e 's/^-O[0-9] / /g' | sed -e 's/ $-O[0-9] / /g')
+export CFLAGS=$(echo $CFLAGS | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2 / /g')
+export CFLAGS="-O0 -g $CFLAGS"
+%endif
+
+./autogen.sh
+%configure \
+ --disable-static \
+ --prefix=%{_prefix} \
+
+make %{?_smp_mflags}
+
+%install
+%make_install
+
+# Remove local archives
+rm -f %{buildroot}%{_libdir}/*.la
+
+
+%post
+/sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%post -n libsystem-sd
+/sbin/ldconfig
+
+%postun -n libsystem-sd -p /sbin/ldconfig
+
+%files
+%defattr(-,root,root,-)
+%{_libdir}/libsystem.so.*
+
+%files devel
+%defattr(-,root,root,-)
+%{_libdir}/libsystem.so
+%{_includedir}/libsystem/config-parser.h
+%{_includedir}/libsystem/dbus-util.h
+%{_includedir}/libsystem/glib-util.h
+%{_includedir}/libsystem/libsystem.h
+%{_libdir}/pkgconfig/libsystem.pc
+
+%files -n libsystem-sd
+%defattr(-,root,root,-)
+%{_libdir}/libsystem-sd.so.*
+
+%files -n libsystem-sd-devel
+%defattr(-,root,root,-)
+%{_libdir}/libsystem-sd.so
+%{_includedir}/libsystem-sd/systemd.h
+%{_libdir}/pkgconfig/libsystem-sd.pc