summaryrefslogtreecommitdiff
path: root/packaging/libdevice-node.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/libdevice-node.spec')
-rw-r--r--packaging/libdevice-node.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/packaging/libdevice-node.spec b/packaging/libdevice-node.spec
index c4b9273..782d7fd 100644
--- a/packaging/libdevice-node.spec
+++ b/packaging/libdevice-node.spec
@@ -10,6 +10,9 @@ BuildRequires: cmake
BuildRequires: pkgconfig(vconf)
BuildRequires: pkgconfig(dlog)
BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gio-2.0)
+
+BuildRequires: pkgconfig(gmock)
%description
development package of library to control OAL APIs
@@ -26,7 +29,10 @@ Library to control OAL APIs (devel)
%setup -q
cp %{SOURCE1} .
%build
-%cmake .
+%cmake -DBUILD_GTESTS=on \
+ .
+ #eol
+
make %{?jobs:-j%jobs}
%install
@@ -39,6 +45,7 @@ make %{?jobs:-j%jobs}
%{_libdir}/*.so.*
%manifest %{name}.manifest
%license LICENSE.APLv2
+%{_bindir}/gtest*
%files devel
%{_includedir}/device-node/*.h