summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJiyoung Yun <jy910.yun@samsung.com>2015-02-27 19:51:46 +0900
committerJiyoung Yun <jy910.yun@samsung.com>2015-03-09 21:39:34 +0900
commit17791aab5269f6392b85694b116c7f7638fd5d62 (patch)
tree2f1a8b0bea6c890deea7e63660dcb5f811cc024c /CMakeLists.txt
parent9854fb4624b6f419fc149698a9783d351249be89 (diff)
downloadlibdevice-node-17791aab5269f6392b85694b116c7f7638fd5d62.tar.gz
libdevice-node-17791aab5269f6392b85694b116c7f7638fd5d62.tar.bz2
libdevice-node-17791aab5269f6392b85694b116c7f7638fd5d62.zip
Backlight structure will replace with display structure. The role and mean of backlight is too restrictive. Display will cover all function of drm, backlight and so on. Change-Id: Icf0a45d2fb522f0f55b7210fabf4a8b5bd77ef3b Signed-off-by: Jiyoung Yun <jy910.yun@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8accafd..f7e3fca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,11 +26,6 @@ SET(HEADERS
include/device-node.h
include/devman_plugin_intf.h)
-SET(HW_HEADERS
- hw/common.h
- hw/backlight.h
- hw/led.h)
-
INCLUDE(devices/CMakeLists.txt)
SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} -fvisibility=hidden")
@@ -61,9 +56,9 @@ FOREACH(hfile ${HEADERS})
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${hfile} DESTINATION include/${PROJECT_NAME})
ENDFOREACH(hfile)
-FOREACH(hfile ${HW_HEADERS})
- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${hfile} DESTINATION include/hw)
-ENDFOREACH(hfile)
+INSTALL(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/hw/ DESTINATION include/hw
+ FILES_MATCHING
+ PATTERN "*.h")
CONFIGURE_FILE(hwcommon.pc.in hwcommon.pc @ONLY)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/hwcommon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)