summaryrefslogtreecommitdiff
path: root/src/crash-stack/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crash-stack/CMakeLists.txt')
-rw-r--r--src/crash-stack/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/crash-stack/CMakeLists.txt b/src/crash-stack/CMakeLists.txt
index 90ec07e..ebe8121 100644
--- a/src/crash-stack/CMakeLists.txt
+++ b/src/crash-stack/CMakeLists.txt
@@ -30,10 +30,11 @@ endif()
# Set compilation options for core dump support
if (${WITH_CORE_DUMP} STREQUAL "ON")
set_property(TARGET ${CRASH_STACK_BIN} APPEND_STRING PROPERTY COMPILE_FLAGS " -DWITH_CORE_DUMP")
+ find_library(EBL_LIBRARY NAMES ebl)
endif()
# Linking
-target_link_libraries(${CRASH_STACK_BIN} dw elf ebl dl stdc++)
+target_link_libraries(${CRASH_STACK_BIN} ${EBL_LIBRARY} dw elf dl stdc++)
# Installing
install(TARGETS ${CRASH_STACK_BIN} DESTINATION libexec)