summaryrefslogtreecommitdiff
path: root/packaging/crash-worker.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/crash-worker.spec')
-rw-r--r--packaging/crash-worker.spec32
1 files changed, 0 insertions, 32 deletions
diff --git a/packaging/crash-worker.spec b/packaging/crash-worker.spec
index baa227e..2d550a9 100644
--- a/packaging/crash-worker.spec
+++ b/packaging/crash-worker.spec
@@ -2,13 +2,11 @@
%define on_off() %{expand:%%{?with_%{1}:ON}%%{!?with_%{1}:OFF}}
%define _with_tests on
-%define _with_logdump on
%define _with_livedumper on
%define _with_crashservice on
%bcond_with doc
%bcond_with sys_assert
%bcond_with tests
-%bcond_with logdump
%bcond_with livedumper
%bcond_with crashservice
@@ -97,10 +95,6 @@ Summary: Livedumper allows to dump core of live process
#Debug mode path - existence of file at path below mean that core file should be generated
%define debugmode_path %{TZ_SYS_ETC}/.debugmode
-#Path for log_dump module
-%define crash_all_log %{TZ_SYS_ALLLOGS}
-%define crash_dump_gen %{TZ_SYS_DUMPGEN}
-
%define upgrade_script_path %{TZ_SYS_RO_SHARE}/upgrade/scripts
%build
@@ -134,14 +128,12 @@ export CFLAGS+=" -Werror"
-DMINICOREDUMPER_BIN_PATH=%{_sbindir}/minicoredumper \
-DMINICOREDUMPER_CONFIG_PATH=%{_sysconfdir}/minicoredumper/minicoredumper.cfg.json \
-DLIVEDUMPER_BIN_PATH=%{_bindir}/livedumper \
- -DLOG_DUMP_BIN_PATH=%{_bindir}/log_dump \
-DDUMP_SYSTEMSTATE_BIN_PATH=%{_bindir}/dump_systemstate \
-DCRASH_STACK_BIN_PATH=%{_libexecdir}/crash-stack \
-DCRASH_POPUP_BIN_PATH=%{_libexecdir}/crash-popup-launch \
-DCRASH_NOTIFY_BIN_PATH=%{_libexecdir}/crash-notify-send \
-DCRASH_TESTS_PATH=%{_libdir}/crash-worker-tests \
-DSYS_ASSERT=%{on_off sys_assert} \
- -DLOG_DUMP=%{on_off logdump} \
-DLIVEDUMPER=%{on_off livedumper} \
-DCRASH_SERVICE=%{on_off crashservice} \
-DUPGRADE_SCRIPT_PATH=%{upgrade_script_path} \
@@ -160,14 +152,6 @@ mkdir -p %{buildroot}%{crash_root_path}
mkdir -p %{buildroot}%{crash_path}
mkdir -p %{buildroot}%{crash_temp}
-# log_dump dir
-%if %{with logdump}
-mkdir -p %{buildroot}%{crash_all_log}
-mkdir -p %{buildroot}%{crash_dump_gen}
-cp dump_scripts/* %{buildroot}%{crash_dump_gen}
-chmod 755 %{buildroot}%{crash_dump_gen}/*
-%endif
-
%post
%if %{with sys_assert}
if [ ! -d /.build ]; then
@@ -186,13 +170,6 @@ fi
/usr/bin/chsmack -a "System" -t %{crash_path}
/usr/bin/chsmack -a "System" -t %{crash_temp}
-%if %{with logdump}
-/usr/bin/chsmack -a "System" -t %{crash_dump_gen}
-/usr/bin/chsmack -a "System" -t %{crash_dump_gen}/module.d
-/usr/bin/chsmack -a "System::Shared" -t %{crash_all_log}
-/usr/bin/chsmack -a "_" %{crash_dump_gen}/module.d/*
-%endif
-
%postun
%if %{with sys_assert}
orig="%{_libdir}/libsys-assert.so"
@@ -227,15 +204,6 @@ sed -i "/${pattern}/D" %{_sysconfdir}/ld.so.preload
%{_libdir}/libcrash-service.so.*
%endif
-%if %{with logdump}
-%dir %{crash_all_log}
-%{crash_dump_gen}/*
-%attr(-,root,root) %{_unitdir}/log_dump.service
-%attr(-,root,root) %{_sysconfdir}/dbus-1/system.d/log_dump.conf
-%attr(-,root,root) %{_datadir}/dbus-1/system-services/org.tizen.system.crash.service
-%attr(0750,system_fw,system_fw) %{_bindir}/log_dump
-%endif
-
%if %{with sys_assert}
%{_libdir}/libsys-assert.so
%{_sysconfdir}/tmpfiles.d/sys-assert.conf