summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMateusz Moscicki <m.moscicki2@partner.samsung.com>2019-07-25 11:02:43 +0200
committerMateusz Moscicki <m.moscicki2@partner.samsung.com>2019-09-26 13:25:02 +0200
commit0d395b1e977387028e9515944b9c4e5731f52f19 (patch)
tree7a27312421487fece9c7d3208c48a4c054bdfdb3 /CMakeLists.txt
parentaa2021fef99fb09e9b1080f613ad9b9d1e790d78 (diff)
downloadcrash-worker-0d395b1e977387028e9515944b9c4e5731f52f19.tar.gz
crash-worker-0d395b1e977387028e9515944b9c4e5731f52f19.tar.bz2
crash-worker-0d395b1e977387028e9515944b9c4e5731f52f19.zip
Add crash manager API
Privileged processes can send a D-Bus method call to create report of any living process. Signature is (iss): - INT (in) PID - STRING (in) dump reason - STRING (out) report path There is a library libcrashservice that sends the D-Bus method call. A function signature is: int livedump_pid(pid_t pid, const char *dump_reason, char *report_path); Change-Id: Id8528bdbaac517d4b5fc649821368e0ff020862f
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0053f4c..df5c180 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,5 +26,12 @@ IF("${LIVEDUMPER}" STREQUAL "ON")
ADD_SUBDIRECTORY(src/livedumper)
ENDIF()
+IF("${CRASH_SERVICE}" STREQUAL "ON")
+ if (NOT "${LIVEDUMPER}" STREQUAL "ON")
+ message(FATAL_ERROR "Livedumper is required to build crash-service")
+ ENDIF()
+ ADD_SUBDIRECTORY(src/crash-service)
+ENDIF()
+
ADD_SUBDIRECTORY(tests)