summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJiwoong Im <jiwoong.im@samsung.com>2016-12-22 17:33:08 +0900
committerJiwoong Im <jiwoong.im@samsung.com>2017-01-11 20:02:55 +0900
commite0774ad8cb34418fe701546627329096d28862bf (patch)
tree00a10ecd31833542d05609423978ec57077e6086 /lib/CMakeLists.txt
parent208e292eb9d6423ae7926c69bae2d294bd6972bd (diff)
downloadbuxton2-e0774ad8cb34418fe701546627329096d28862bf.tar.gz
buxton2-e0774ad8cb34418fe701546627329096d28862bf.tar.bz2
buxton2-e0774ad8cb34418fe701546627329096d28862bf.zip
- Add hashtable in buxton daemon to reduce db access. Add hashtable in client for repeated get operation on the same key. Send notis to client after sending result of set operation. - Brief profiling data +---------------------------------------------------+ | - Gerenal set/get operation | | vconf set average : 5.420375 ms -> 3.430805 ms | | vconf get average : 1.721345 ms -> 0.592360 ms | | | | - Repeated get operation on the same key | | vconf get average : 1.721345 ms -> 0.010990 ms | +---------------------------------------------------+ Change-Id: Ib7ffd75dbd3bb11b76e9729f4177605848c47dfe Signed-off-by: Jiwoong Im <jiwoong.im@samsung.com>
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 34bf0a0..59b2e7b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -4,6 +4,7 @@ SET(TARGET buxton2)
SET(SRC buxton2.c
../common/proto.c
../common/serialize.c
+ ../common/cache.c
../common/common.c)
INCLUDE_DIRECTORIES(include)
ADD_LIBRARY(${TARGET} SHARED ${SRC})