summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSuchang Woo <suchang.woo@samsung.com>2015-07-16 17:12:54 +0900
committerSuchang Woo <suchang.woo@samsung.com>2015-07-16 17:28:30 +0900
commitd966429452d4ff6a3527f0deb8db63be5b87f720 (patch)
treea811fe0a17e1c6b69868cf1176eb99815227238b /lib/CMakeLists.txt
parent99b1d99a4f93a6bf0786abc6ae5ad1f3d9415933 (diff)
downloadbuxton2-d966429452d4ff6a3527f0deb8db63be5b87f720.tar.gz
buxton2-d966429452d4ff6a3527f0deb8db63be5b87f720.tar.bz2
buxton2-d966429452d4ff6a3527f0deb8db63be5b87f720.zip
Initial importHEADmaster
Signed-off-by: Suchang Woo <suchang.woo@samsung.com>
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 0000000..0f5b356
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,23 @@
+# libbuxton2.so build
+SET(TARGET buxton2)
+
+SET(SRC buxton2.c
+ ../common/proto.c
+ ../common/serialize.c
+ ../common/common.c)
+INCLUDE_DIRECTORIES(include)
+ADD_LIBRARY(${TARGET} SHARED ${SRC})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES
+ COMPILE_FLAGS "-fvisibility=hidden"
+ VERSION ${VERSION}
+ SOVERSION ${MAJVER}
+)
+TARGET_LINK_LIBRARIES(${TARGET} ${PKGS_LDFLAGS})
+INSTALL(TARGETS ${TARGET} DESTINATION ${LIB_INSTALL_DIR} COMPONENT RuntimeLibraries)
+
+# buxton2.pc
+CONFIGURE_FILE(buxton2.pc.in buxton2.pc @ONLY)
+INSTALL(FILES buxton2.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+
+# buxton2.h
+INSTALL(FILES include/buxton2.h DESTINATION ${INCLUDE_INSTALL_DIR})