summaryrefslogtreecommitdiff
path: root/packaging/optee-os.spec
diff options
context:
space:
mode:
authorr.tyminski <r.tyminski@partner.samsung.com>2017-11-28 13:54:23 +0100
committerr.tyminski <r.tyminski@partner.samsung.com>2017-11-28 13:54:23 +0100
commitae7edc30d01000822bb5cbeae18ec390ee7ddd9e (patch)
treeab44bef17d7c24367153a302230ec9a2cf505518 /packaging/optee-os.spec
parent69f182f39ed30d83cf16546a79a43c4367a08388 (diff)
downloadtef-optee_os-ae7edc30d01000822bb5cbeae18ec390ee7ddd9e.tar.gz
tef-optee_os-ae7edc30d01000822bb5cbeae18ec390ee7ddd9e.tar.bz2
tef-optee_os-ae7edc30d01000822bb5cbeae18ec390ee7ddd9e.zip
Build artik710 and rpi3 in one spec file.
Change spec file to be more generic. Change-Id: Iefbf5668b25242a811f5e553cc79304ab95830b5
Diffstat (limited to 'packaging/optee-os.spec')
-rw-r--r--packaging/optee-os.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/packaging/optee-os.spec b/packaging/optee-os.spec
new file mode 100644
index 0000000..7ebf7c2
--- /dev/null
+++ b/packaging/optee-os.spec
@@ -0,0 +1,92 @@
+Name: optee-os
+Summary: OpTEE OS with userspace libraries and devkit for OpTEE OS.
+Version: 2.4.0
+Release: 1%{?dist}
+Group: Security/Testing
+License: BSD-2-Clause
+URL: https://github.com/OP-TEE/optee_os
+Source0: %{name}-%{version}.tar.gz
+ExclusiveArch: armv6l armv7hl armv7l aarch64
+
+Provides: tee-pager.bin
+Provides: tee.bin
+Provides: optee-os-ta
+
+BuildRequires: make
+BuildRequires: python
+BuildRequires: openssl
+
+%description
+Trusted execution enviroment in Linux using the ARM® TrustZone® technology.
+
+%package -n optee-os-rpi3
+Summary: OPTEE trusted operation system.
+Group: Security/Testing
+
+%description -n optee-os-rpi3
+Trusted execution enviroment in Linux using the ARM® TrustZone® technology.
+
+%package ta
+Summary: OpTEE OS userspace libraries and devkit for OpTEE OS.
+Group: Security/Testing
+
+%description ta
+Trusted execution enviroment in Linux using the ARM® TrustZone® technology.
+
+%package -n optee-os-artik710
+Summary: OPTEE trusted operation system.
+Group: Security/Testing
+
+%description -n optee-os-artik710
+Trusted execution enviroment in Linux using the ARM® TrustZone® technology.
+
+%if "%{build_type}" == "DEBUG"
+%define log_env CFG_TEE_CORE_LOG_LEVEL=4 DEBUG=1
+%else
+%define log_env CFG_TEE_CORE_LOG_LEVEL=0 DEBUG=0
+%endif
+
+%if %{__isa_bits} == 64
+%define compile_arch CFG_ARM64_core=y
+%else
+%define compile_arch CFG_WITH_VFP=n
+%endif
+
+%define compile_flags CROSS_COMPILE="" CROSS_COMPILE64="" CFLAGS=-lgcc_eh CFG_LIBUTEE_TUI=n CFLAGS=-lgcc_eh CFG_LIBUTEE_TUI=n %{log_env} %{compile_arch}
+
+%define export_dir export-ta_arm%{__isa_bits}
+%define out_export_dir opt/optee/
+
+%prep
+%setup -q
+
+%build
+make %{compile_flags} PLATFORM=rpi3
+make %{compile_flags} PLATFORM=s5p6818 out/arm-plat-s5p6818/core/tee.bin
+
+%install
+%define buildplat rpi3
+%define plat_dir arm-plat-%{buildplat}
+mkdir -p %{buildroot}/boot/
+mkdir -p %{buildroot}/%{out_export_dir}
+
+cp -p out/%{plat_dir}/core/tee-pager.bin %{buildroot}/boot/
+cp -p out/%{plat_dir}/core/tee.bin %{buildroot}/boot/
+cp -rf out/%{plat_dir}/%{export_dir} %{buildroot}/%{out_export_dir}/
+
+%define buildplat s5p6818
+%define plat_dir arm-plat-%{buildplat}
+
+cp -p out/%{plat_dir}/core/tee.bin %{buildroot}/boot/tee-artik.bin
+
+%clean
+
+%files -n optee-os-rpi3
+/boot/tee-pager.bin
+/boot/tee.bin
+
+%files ta
+/%{out_export_dir}/%{export_dir}
+
+%files -n optee-os-artik710
+/boot/tee-artik.bin