summaryrefslogtreecommitdiff
path: root/packaging/optee-os-rpi3.spec
diff options
context:
space:
mode:
authorr.tyminski <r.tyminski@partner.samsung.com>2017-06-14 10:31:43 +0200
committerr.tyminski <r.tyminski@partner.samsung.com>2017-09-04 13:22:50 +0200
commit96631b362fc12b546cb096d763981c7128bf0230 (patch)
treec80f0e4cee6e1a9fc2c9832ca54f29cf962130b6 /packaging/optee-os-rpi3.spec
parent146aec115cd05a164a88e6d7b07435c57a33817f (diff)
downloadtef-optee_os-96631b362fc12b546cb096d763981c7128bf0230.tar.gz
tef-optee_os-96631b362fc12b546cb096d763981c7128bf0230.tar.bz2
tef-optee_os-96631b362fc12b546cb096d763981c7128bf0230.zip
Added packaging and necessary changes for gbs compilation.
Packaging for optee-os binary and optee-os TA devkit. Modify pem_to_pub_c.py and sign.py script to use openssl if pycrypto is not available. Allow to disable Terminal User Interface (TUI) from compilation. Compile 32-bit TA devkit with CFG_WITH_VFP=n. GBS compile with softfp. Change-Id: If3ad89d8871c1a8f7f1a519b07941316acdbdd14
Diffstat (limited to 'packaging/optee-os-rpi3.spec')
-rw-r--r--packaging/optee-os-rpi3.spec41
1 files changed, 41 insertions, 0 deletions
diff --git a/packaging/optee-os-rpi3.spec b/packaging/optee-os-rpi3.spec
new file mode 100644
index 0000000..4d5b2fc
--- /dev/null
+++ b/packaging/optee-os-rpi3.spec
@@ -0,0 +1,41 @@
+%define buildplat rpi3
+%define compile_flags CROSS_COMPILE="" CROSS_COMPILE64="" PLATFORM=%{buildplat} CFLAGS=-lgcc_eh CFG_LIBUTEE_TUI=n CFG_TEE_CORE_LOG_LEVEL=3 DEBUG=0
+%if %{__isa_bits} == 64
+%define compile_arch %{compile_flags} CFG_ARM64_core=y
+%else
+%define compile_arch %{compile_flags}
+%endif
+
+Name: optee-os
+Summary: OPTEE trusted operation system.
+Version: 2.4.0
+Release: 1%{?dist}
+Group: Security/Testing
+License: BSD-2-Clause
+URL: https://github.com/OP-TEE/optee_os
+Source0: %{name}-%{version}.tar.gz
+
+Provides: tee-pager.bin
+
+BuildRequires: make
+BuildRequires: python
+BuildRequires: openssl
+
+%description
+Trusted execution enviroment in Linux using the ARMĀ® TrustZoneĀ® technology.
+
+%prep
+%setup -q
+
+%build
+make %{compile_arch} out/arm-plat-%{buildplat}/core/tee-pager.bin
+
+%install
+mkdir -p %{buildroot}/boot/
+
+cp -p %{_builddir}/%{name}-%{version}/out/arm-plat-%{buildplat}/core/tee-pager.bin %{buildroot}/boot/
+
+%clean
+
+%files
+/boot/tee-pager.bin