summaryrefslogtreecommitdiff
path: root/build/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'build/CMakeLists.txt')
-rw-r--r--build/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/build/CMakeLists.txt b/build/CMakeLists.txt
new file mode 100644
index 0000000..338e7ce
--- /dev/null
+++ b/build/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright (c) 2011 Samsung Electronics Co., Ltd All Rights Reserved
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# @file CMakeLists.txt
+# @brief
+#
+
+CONFIGURE_FILE(libwebappenc.pc.in libwebappenc.pc @ONLY)
+
+INSTALL(FILES
+ ${CMAKE_BINARY_DIR}/build/libwebappenc.pc
+ DESTINATION
+ ${LIB_INSTALL_DIR}/pkgconfig
+ )