summaryrefslogtreecommitdiff
path: root/srcs/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwook Tak <k.tak@samsung.com>2016-07-18 12:54:40 +0900
committerKyungwook Tak <k.tak@samsung.com>2016-07-19 11:32:22 +0900
commit99ad3b114bce6ba5743f74c39079d524781134cd (patch)
treee7a247f32834b4d2ba00bbcfcc7a786b52cd8a01 /srcs/CMakeLists.txt
parentf72179753846682e783bbc4dbe1a3a570e7fac23 (diff)
downloadlibwebappenc-99ad3b114bce6ba5743f74c39079d524781134cd.tar.gz
libwebappenc-99ad3b114bce6ba5743f74c39079d524781134cd.tar.bz2
libwebappenc-99ad3b114bce6ba5743f74c39079d524781134cd.zip
Support platform upgrade case
secure-storage is removed since Tizen platform version 3.0. downloaded web apps encryption works based on different key from lower than 3.0. secure-storage used DUK(device unique key with seed(pkgid)) as DEK. If downloaded app cannot find DEK when decrypt, it's considered as encrypted lower than 3.0 case. So webappenc creates DEK and uses algorithm which had been used lower than 3.0 in secure-storage. For now it's hard to save newly created old key in key-manager because migrated web app is considered as global app and the case would be found in decryption time (by web app launcher) who don't have permission to save in system db of key-manager with "/System" label. Permission policy of system db of key-manager should be changed OR migrated app should not be global app (it should be downloaded normal app) to save created key in key-manager. Change-Id: I9b8516184cce9f43b328e290c15127151e5c861e Signed-off-by: Kyungwook Tak <k.tak@samsung.com>
Diffstat (limited to 'srcs/CMakeLists.txt')
-rw-r--r--srcs/CMakeLists.txt27
1 files changed, 23 insertions, 4 deletions
diff --git a/srcs/CMakeLists.txt b/srcs/CMakeLists.txt
index b95531b..3de6d18 100644
--- a/srcs/CMakeLists.txt
+++ b/srcs/CMakeLists.txt
@@ -1,11 +1,30 @@
+# Copyright (c) 2016 Samsung Electronics Co., Ltd All Rights Reserved
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# @file CMakeLists.txt
+# @author
+# @brief
+#
+
################################################################################
# for libwebappenc.so
################################################################################
-
SET(WEB_APP_ENC_SOURCES
- ${CMAKE_CURRENT_SOURCE_DIR}/web_app_enc.c
- ${CMAKE_CURRENT_SOURCE_DIR}/key_handler.c
- ${CMAKE_CURRENT_SOURCE_DIR}/crypto_service.c
+ web_app_enc.c
+ key_handler.c
+ crypto_service.c
+ decrypt_migrated_wgt.c
)
INCLUDE_DIRECTORIES(