summaryrefslogtreecommitdiff
path: root/src/manager/sqlcipher/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/manager/sqlcipher/CMakeLists.txt')
-rw-r--r--src/manager/sqlcipher/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/manager/sqlcipher/CMakeLists.txt b/src/manager/sqlcipher/CMakeLists.txt
index dd7c6543..7ee930a3 100644
--- a/src/manager/sqlcipher/CMakeLists.txt
+++ b/src/manager/sqlcipher/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2020 Samsung Electronics Co., Ltd. All rights reserved
+# Copyright (c) 2020-2024 Samsung Electronics Co., Ltd. All rights reserved
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -21,7 +21,7 @@ ADD_LIBRARY(
SET_TARGET_PROPERTIES(
${DUMP_LEGACY_DB_LIBNAME}
PROPERTIES
- COMPILE_FLAGS "-fvisibility=hidden -Wl,--no-undefined"
+ COMPILE_FLAGS "-fvisibility=hidden -Wl,--no-undefined,-Wno-return-local-addr"
)
INSTALL(