summaryrefslogtreecommitdiff
path: root/packaging/key-manager.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/key-manager.spec')
-rw-r--r--packaging/key-manager.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/packaging/key-manager.spec b/packaging/key-manager.spec
index b6af62a8..c6089ded 100644
--- a/packaging/key-manager.spec
+++ b/packaging/key-manager.spec
@@ -1,3 +1,7 @@
+%global watchdog_enabled 1
+%global watchdog_timeout_sec 60
+%global watchdog_notify_sec 20
+
Name: key-manager
Summary: Central Key Manager and utilities
Version: 0.1.23
@@ -25,6 +29,9 @@ BuildRequires: pkgconfig(cynara-creds-socket)
BuildRequires: pkgconfig(libtzplatform-config)
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(pkgmgr)
+%if 0%{?watchdog_enabled}
+BuildRequires: pkgconfig(argos_watchdog)
+%endif
BuildRequires: boost-devel
BuildRequires: ca-certificates-devel
#Requires(pre): tizen-platform-config-tools
@@ -124,7 +131,6 @@ cp -a %{SOURCE1004} .
export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
%endif
-
export LDFLAGS+="-Wl,--rpath=%{_libdir},-Bsymbolic-functions "
%cmake . -DVERSION=%{version} \
@@ -147,8 +153,13 @@ export LDFLAGS+="-Wl,--rpath=%{_libdir},-Bsymbolic-functions "
-DINITIAL_VALUES_DIR=%{initial_values_dir} \
-DDB_TEST_DIR=%{db_test_dir} \
-DCA_CERTS_DIR=%{ca_certs_dir} \
- -DUPGRADE_SCRIPT_DIR=%{upgrade_script_dir} \
- -DUPGRADE_DATA_DIR=%{upgrade_data_dir}
+%if 0%{?watchdog_enabled}
+ -DWATCHDOG_ENABLED=%{watchdog_enabled} \
+ -DWATCHDOG_TIMEOUT_SEC=%{watchdog_timeout_sec} \
+ -DWATCHDOG_NOTIFY_SEC=%{watchdog_notify_sec} \
+%endif
+ -DUPGRADE_DATA_DIR=%{upgrade_data_dir} \
+ -DUPGRADE_SCRIPT_DIR=%{upgrade_script_dir}
make %{?jobs:-j%jobs}