summaryrefslogtreecommitdiff
path: root/build/CMakeLists.txt
diff options
context:
space:
mode:
authorBartlomiej Grzelewski <b.grzelewski@samsung.com>2014-06-03 14:26:06 +0200
committerBartlomiej Grzelewski <b.grzelewski@samsung.com>2014-09-12 14:56:41 +0200
commit65b129fa689bc6be4086d1e16332acb5ae64bdbe (patch)
tree6b8294aa8578afc5680a4ed9dc0672c2b707b02f /build/CMakeLists.txt
parentb69ec2c5cc822989ad6e5fc3d5fc53bb1b3d942b (diff)
downloadkey-manager-65b129fa689bc6be4086d1e16332acb5ae64bdbe.tar.gz
key-manager-65b129fa689bc6be4086d1e16332acb5ae64bdbe.tar.bz2
key-manager-65b129fa689bc6be4086d1e16332acb5ae64bdbe.zip
Move pc file to build directory.
Add dummy responses to Control protocol. Change-Id: I76d44f1d0dc52daa455ea7283bfd2435715d3c7c
Diffstat (limited to 'build/CMakeLists.txt')
-rw-r--r--build/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/build/CMakeLists.txt b/build/CMakeLists.txt
index 02ca0258..baf97d4a 100644
--- a/build/CMakeLists.txt
+++ b/build/CMakeLists.txt
@@ -13,7 +13,15 @@
# limitations under the License.
#
# @file CMakeLists.txt
-# @author Tomasz Swierczek (t.swierczek@samsung.com)
+# @author Barlomiej Grzelewski (b.grzelewski@samsung.com)
+# @author Zofia Abramowska (z.abramowska@samsung.com)
+# @brief
#
-ADD_SUBDIRECTORY(key-manager)
+CONFIGURE_FILE(key-manager.pc.in key-manager.pc @ONLY)
+
+INSTALL(FILES
+ ${CMAKE_BINARY_DIR}/build/key-manager.pc
+ DESTINATION
+ ${LIB_INSTALL_DIR}/pkgconfig
+ )