summaryrefslogtreecommitdiff
path: root/tests/transec/CMakeLists.txt
diff options
context:
space:
mode:
authorsangwan.kwon <sangwan.kwon@samsung.com>2017-03-24 18:17:38 +0900
committersangwan.kwon <sangwan.kwon@samsung.com>2017-03-24 18:17:38 +0900
commit97b1eb4200762e04ca793b5e0c2bf0bfe2541a8c (patch)
tree0eeb21670312d8d581a53cec55c178de121b5023 /tests/transec/CMakeLists.txt
parent11fd00766270ad3fc740b9f1e7414b58f04ad501 (diff)
downloadcert-svc-97b1eb4200762e04ca793b5e0c2bf0bfe2541a8c.tar.gz
cert-svc-97b1eb4200762e04ca793b5e0c2bf0bfe2541a8c.tar.bz2
cert-svc-97b1eb4200762e04ca793b5e0c2bf0bfe2541a8c.zip
Move trust-anchor to seperate git
Change-Id: Ibb55a1f8f64759aee36a597bd66cf2d9f9111a39 Signed-off-by: sangwan.kwon <sangwan.kwon@samsung.com>
Diffstat (limited to 'tests/transec/CMakeLists.txt')
-rw-r--r--tests/transec/CMakeLists.txt64
1 files changed, 0 insertions, 64 deletions
diff --git a/tests/transec/CMakeLists.txt b/tests/transec/CMakeLists.txt
deleted file mode 100644
index 8d06282..0000000
--- a/tests/transec/CMakeLists.txt
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright (c) 2017 Samsung Electronics Co., Ltd All Rights Reserved
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-# @file CMakeLists.txt
-# @author Sangwan Kwon (sangwan.kwon@samsung.com)
-# @breif
-#
-SET(TEST_SRCS
- main.cpp
- test-util.cpp
- test-capi-installer.cpp
- test-capi-launcher.cpp
- test-installer.cpp
- test-launcher.cpp
- test-certificate.cpp
-)
-
-SET(TEST_TRANSEC_PATH "${CERT_SVC_TESTS}/transec")
-ADD_DEFINITIONS("-DTEST_TRANSEC_PATH=\"${TEST_TRANSEC_PATH}\"")
-
-INCLUDE_DIRECTORIES(
- .
- SYSTEM
- ${PROJECT_SOURCE_DIR}/src/transec
-)
-
-ADD_EXECUTABLE(${TARGET_TRANSEC_TEST}
- ${TEST_SRCS}
- ${DPL_TEST_SOURCES}
-)
-
-TARGET_LINK_LIBRARIES(${TARGET_TRANSEC_TEST}
- ${TARGET_VCORE_LIB}
- ${TARGET_TRANSEC_LIB}
- ${TEST_DEP_LIBRARIES}
-)
-
-INSTALL(TARGETS
- ${TARGET_TRANSEC_TEST}
- DESTINATION
- ${BIN_DIR}
- PERMISSIONS
- OWNER_READ
- OWNER_WRITE
- OWNER_EXECUTE
- GROUP_READ
- GROUP_EXECUTE
- WORLD_READ
- WORLD_EXECUTE
-)
-
-ADD_SUBDIRECTORY(resource)
-ADD_SUBDIRECTORY(script)