summaryrefslogtreecommitdiff
path: root/testcase/build/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testcase/build/configure.ac')
-rw-r--r--testcase/build/configure.ac46
1 files changed, 46 insertions, 0 deletions
diff --git a/testcase/build/configure.ac b/testcase/build/configure.ac
new file mode 100644
index 0000000..ec4cd95
--- /dev/null
+++ b/testcase/build/configure.ac
@@ -0,0 +1,46 @@
+AC_PREREQ(2.52)
+
+AC_INIT([mm-hal-testcase], [0.8.0])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_CONFIG_HEADERS([config.h:config.hin])
+AC_CONFIG_MACRO_DIR([m4])
+
+# Checks for programs.
+m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+AC_PROG_CC
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AC_C_CONST
+AC_HEADER_STDBOOL
+AC_HEADER_STDC
+AC_HEADER_TIME
+AC_PROG_GCC_TRADITIONAL
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+AC_ARG_ENABLE(tc-camera, AC_HELP_STRING([--enable-tc-camera], [enable tc-camera]),
+[
+ case "${enableval}" in
+ yes) TC_CAMERA=yes ;;
+ no) TC_CAMERA=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-tc-camera) ;;
+ esac
+],[TC_CAMERA=no])
+AM_CONDITIONAL([TC_CAMERA], [test "x$TC_CAMERA" = "xyes"])
+
+PKG_CHECK_MODULES(GLIB, glib-2.0)
+AC_SUBST(GLIB_CFLAGS)
+AC_SUBST(GLIB_LIBS)
+
+PKG_CHECK_MODULES(DLOG, dlog)
+AC_SUBST(DLOG_CFLAGS)
+AC_SUBST(DLOG_LIBS)
+
+# Checks for library functions.
+AC_CONFIG_FILES([
+Makefile
+testcase/Makefile
+testcase/camera/Makefile
+])
+AC_OUTPUT
+