summaryrefslogtreecommitdiff
path: root/testcase/audio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testcase/audio/Makefile.am')
-rw-r--r--testcase/audio/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/testcase/audio/Makefile.am b/testcase/audio/Makefile.am
new file mode 100644
index 0000000..779de11
--- /dev/null
+++ b/testcase/audio/Makefile.am
@@ -0,0 +1,18 @@
+# with gtest
+bin_PROGRAMS = audio_haltests
+
+audio_haltests_SOURCES = \
+ audio_haltests.cpp
+
+audio_haltests_CPPFLAGS = \
+ $(DLOG_CFLAGS)\
+ $(SYSTEM_INFO_CFLAGS)\
+ -I$(srcdir)/../../include/audio
+
+audio_haltests_LDADD = \
+ -ldl\
+ -lgtest\
+ $(top_builddir)/src/audio/libaudio_hal_interface.la\
+ $(DLOG_LIBS)\
+ $(SYSTEM_INFO_LIBS)
+