summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@open.eurogiciel.org>2014-06-25 16:23:39 +0200
committerManuel Bachmann <manuel.bachmann@open.eurogiciel.org>2014-06-25 16:23:39 +0200
commite527eb103c2f033168dc0068a1f5521f15cd1383 (patch)
tree37b64201b379fe7c56e85de7cc79c46eb7349ac9 /CMakeLists.txt
parent7e3e82b79e27d6e481f3470299257c6d3cc7812e (diff)
downloadlibmedia-thumbnail-e527eb103c2f033168dc0068a1f5521f15cd1383.tar.gz
libmedia-thumbnail-e527eb103c2f033168dc0068a1f5521f15cd1383.tar.bz2
libmedia-thumbnail-e527eb103c2f033168dc0068a1f5521f15cd1383.zip
Instead of using a "GMainLoop" element in the main thread, we now
create a separate thread which will initiate the loop and do the socket listening logic. This avoids conflicting with the "GMainLoop" created by Ecore_Evas, which produces lots of warnings and errors. Bug-Tizen: TC-21 Change-Id: I453a21df649b256b63c96d4f274122c692aaf2f0 Signed-off-by: Manuel Bachmann <manuel.bachmann@open.eurogiciel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6a2780..39c3a15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,7 +44,7 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/src/include
INCLUDE(FindPkgConfig)
pkg_check_modules(pkgs REQUIRED
glib-2.0 gthread-2.0 dlog mm-fileinfo drm-client aul
-libexif ecore-evas evas mmutil-imgp mmutil-jpeg heynoti libmedia-utils vconf libtzplatform-config)
+libexif ecore ecore-evas evas mmutil-imgp mmutil-jpeg heynoti libmedia-utils vconf libtzplatform-config)
FOREACH(flag ${pkgs_CFLAGS})