summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSeungbae Shin <seungbae.shin@samsung.com>2022-04-01 16:14:23 +0900
committerSeungbae Shin <seungbae.shin@samsung.com>2022-05-04 12:05:27 +0900
commit7f2c8044d67cbe36b27a894125fc1904b047122e (patch)
treeb2e5fba63341165cea69a06b59edd481543394a0 /CMakeLists.txt
parentfded5a0003873d09f23fc233c7342f8083d1b961 (diff)
downloadlibmedia-service-7f2c8044d67cbe36b27a894125fc1904b047122e.tar.gz
libmedia-service-7f2c8044d67cbe36b27a894125fc1904b047122e.tar.bz2
libmedia-service-7f2c8044d67cbe36b27a894125fc1904b047122e.zip
Refactoring ebook plugin
- Apply strategy pattern - Separate files for classes and interfaces Change-Id: Icd06ad64b41ba7f799fa445cb12e2a6af9c99fbf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 924d079..9d74a25 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ SET(HASH_SRCS
SET(EBOOKPLUGIN_SRCS
plugin/media-ebook-plugin.cpp
+ plugin/media-ebook-plugin-regmatch.cpp
+ plugin/media-ebook-plugin-dbinserter.cpp
+ plugin/media-ebook-plugin-pdf.cpp
+ plugin/media-ebook-plugin-epub.cpp
)
SET(CONTENTPLUGIN_SRCS
plugin/media-content-plugin.c