summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinhyeok <i_bc.kim@samsung.com>2015-06-25 16:49:28 +0900
committerinhyeok <i_bc.kim@samsung.com>2015-06-26 11:07:41 +0900
commit7e72265b2a4deca07195129f428769811ea3873d (patch)
treea22a64344848526120270a6e9fed00f89fe4adcc /configure.ac
parentcba5a315ca8abb87ec935048647feaa129f5c277 (diff)
downloadaudio-session-manager-7e72265b2a4deca07195129f428769811ea3873d.tar.gz
audio-session-manager-7e72265b2a4deca07195129f428769811ea3873d.tar.bz2
audio-session-manager-7e72265b2a4deca07195129f428769811ea3873d.zip
[Version] Release 0.3.0 [Profile] Common [Issue Type] Migration Merged main changes - Update vconftool for SoundStatus initialize - Apply ASLR - Replace msgqueue to gdbus - Revise return value of asm callback in asm_testsuite - Support container Change-Id: If8fc14a03f1f00a45c7163d9f21a8df8de04f559 Signed-off-by: inhyeok <i_bc.kim@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 24c96af..b1fa5a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,7 @@ AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
# Checks for libraries.
-PKG_CHECK_MODULES(AUDIOSESSIONMGR, glib-2.0 gthread-2.0)
+PKG_CHECK_MODULES(AUDIOSESSIONMGR, glib-2.0 gthread-2.0 gio-2.0)
AC_SUBST(AUDIOSESSIONMGR_CFLAGS)
AC_SUBST(AUDIOSESSIONMGR_LIBS)
@@ -30,6 +30,28 @@ PKG_CHECK_MODULES(VCONF, vconf)
AC_SUBST(VCONF_CFLAGS)
AC_SUBST(VCONF_LIBS)
+PKG_CHECK_MODULES(GIO, gio-2.0)
+AC_SUBST(GIO_CFLAGS)
+AC_SUBST(GIO_LIBS)
+
+dnl use security ---------------------------------------------------------------
+AC_ARG_ENABLE(security, AC_HELP_STRING([--enable-security], [using security]),
+[
+case "${enableval}" in
+ yes) USE_SECURITY=yes ;;
+ no) USE_SECURITY=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-security) ;;
+esac
+],[USE_SECURITY=no])
+
+if test "x$USE_SECURITY" = "xyes"; then
+ PKG_CHECK_MODULES(SECURITY, security-server)
+ AC_SUBST(SECURITY_CFLAGS)
+ AC_SUBST(SECURITY_LIBS)
+fi
+AM_CONDITIONAL(USE_SECURITY, test "x$USE_SECURITY" = "xyes")
+dnl end ------------------------------------------------------------------------
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([fcntl.h stdlib.h sys/time.h unistd.h])