summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinhyeok <i_bc.kim@samsung.com>2015-06-25 16:49:28 +0900
committerinhyeok <i_bc.kim@samsung.com>2015-06-26 11:07:41 +0900
commit7e72265b2a4deca07195129f428769811ea3873d (patch)
treea22a64344848526120270a6e9fed00f89fe4adcc /Makefile.am
parentcba5a315ca8abb87ec935048647feaa129f5c277 (diff)
downloadaudio-session-manager-7e72265b2a4deca07195129f428769811ea3873d.tar.gz
audio-session-manager-7e72265b2a4deca07195129f428769811ea3873d.tar.bz2
audio-session-manager-7e72265b2a4deca07195129f428769811ea3873d.zip
[Version] Release 0.3.0 [Profile] Common [Issue Type] Migration Merged main changes - Update vconftool for SoundStatus initialize - Apply ASLR - Replace msgqueue to gdbus - Revise return value of asm callback in asm_testsuite - Support container Change-Id: If8fc14a03f1f00a45c7163d9f21a8df8de04f559 Signed-off-by: inhyeok <i_bc.kim@samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 89b325d..ec59cde 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = . \
AM_CFLAGS = $(AUDIOSESSIONMGR_CFLAGS)
lib_LTLIBRARIES = libaudio-session-mgr.la
-libaudio_session_mgr_la_SOURCES = $(srcdir)/src/audio-session-mgr.c
+libaudio_session_mgr_la_SOURCES = $(srcdir)/src/audio-session-mgr.c
libaudio_session_mgr_la_LIBADD = $(AUDIOSESSIONMGR_LIBS) $(VCONF_LIBS) $(MMCOMMON_LIBS)
libaudio_session_mgr_la_LDFLAGS = -Wl,-init, __ASM_init_module
@@ -12,6 +12,11 @@ libaudio_session_mgr_la_LDFLAGS += -Wl,-fini, __ASM_fini_module
libaudio_session_mgr_la_CPPFLAGS = -I$(srcdir)/include -DUSE_VCONF $(VCONF_CFLAGS) $(MMCOMMON_CFLAGS)
+if USE_SECURITY
+libaudio_session_mgr_la_CPPFLAGS += $(SECURITY_CFLAGS) -DUSE_SECURITY
+libaudio_session_mgr_la_LIBADD += $(SECURITY_LIBS)
+endif
+
libaudio_session_mgr_la_CPPFLAGS += $(MMLOG_CFLAGS) -DMMF_LOG_OWNER=0x00800000 -DMMF_DEBUG_PREFIX=\"MMF-SESSIONMGR\"
libaudio_session_mgr_la_LIBADD += $(MMLOG_LIBS)