summaryrefslogtreecommitdiff
path: root/runtimes/pure_arm_compute/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/pure_arm_compute/CMakeLists.txt')
-rw-r--r--runtimes/pure_arm_compute/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/runtimes/pure_arm_compute/CMakeLists.txt b/runtimes/pure_arm_compute/CMakeLists.txt
index 2a26a7bf2..32a0ca7ac 100644
--- a/runtimes/pure_arm_compute/CMakeLists.txt
+++ b/runtimes/pure_arm_compute/CMakeLists.txt
@@ -9,11 +9,11 @@ file(GLOB_RECURSE SOURCES "src/*.cc")
add_library(nnapi_pure_arm_compute SHARED ${SOURCES})
# To ignore compiler warnings from ARM Compute Library
target_compile_options(nnapi_pure_arm_compute PRIVATE -Wno-ignored-attributes)
-target_include_directories(nnapi_pure_arm_compute PUBLIC ${NNFW_INCLUDE_DIR})
target_include_directories(nnapi_pure_arm_compute PUBLIC src)
if(BUILD_TFLITE_BENCHMARK_MODEL)
target_compile_definitions(nnapi_pure_arm_compute PUBLIC "TFLITE_PROFILING_ENABLED")
endif()
+target_link_libraries(nnapi_pure_arm_compute nnfw-header)
target_link_libraries(nnapi_pure_arm_compute arm_compute arm_compute_ex)
target_link_libraries(nnapi_pure_arm_compute nnfw_lib_cpp14 nnfw_lib_misc nnfw_lib_profiling)
@@ -23,7 +23,6 @@ endif()
set_target_properties(nnapi_pure_arm_compute PROPERTIES OUTPUT_NAME neuralnetworks)
install(TARGETS nnapi_pure_arm_compute DESTINATION lib/pureacl RENAME neuralnetworks)
-install(TARGETS nnapi_pure_arm_compute DESTINATION lib RENAME neuralnetworks)
# To prevent undefined references
add_executable(pure_arm_compute_symbolcheck symbolcheck.cpp)