summaryrefslogtreecommitdiff
path: root/runtimes/nn/runtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/nn/runtime/CMakeLists.txt')
-rw-r--r--runtimes/nn/runtime/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/runtimes/nn/runtime/CMakeLists.txt b/runtimes/nn/runtime/CMakeLists.txt
new file mode 100644
index 000000000..487c4e0c4
--- /dev/null
+++ b/runtimes/nn/runtime/CMakeLists.txt
@@ -0,0 +1,29 @@
+SET (CUR_INCS
+ ${CMAKE_CURRENT_SOURCE_DIR}/include
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+SET (INC_DIRS
+ ${INC_DIRS}
+ ${CUR_INCS}
+ PARENT_SCOPE
+)
+
+SET (CUR_SRCS
+ ${CMAKE_CURRENT_SOURCE_DIR}/NeuralNetworks.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/ModelBuilder.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/CompilationBuilder.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/ExecutionBuilder.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/Memory.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/Callbacks.cpp)
+
+SET (SRCS
+ ${SRCS}
+ ${CUR_SRCS}
+ PARENT_SCOPE
+)
+
+#####################################################################
+# TODO-NNRT: Remove below rules for test executable later
+# Test executables
+#####################################################################
+include_directories(${LIB_RUNTIME} PRIVATE include ${INC_DIRS})