summaryrefslogtreecommitdiff
path: root/runtimes/nn/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/nn/CMakeLists.txt')
-rw-r--r--runtimes/nn/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/runtimes/nn/CMakeLists.txt b/runtimes/nn/CMakeLists.txt
new file mode 100644
index 000000000..7834594c3
--- /dev/null
+++ b/runtimes/nn/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Library `runtime` which is actually libneuralnetworks.so
+if(CMAKE_VERSION VERSION_LESS 3.1.0)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
+else(CMAKE_VERSION VERSION_LESS 3.1.0)
+ set(CMAKE_CXX_STANDARD 14)
+endif(CMAKE_VERSION VERSION_LESS 3.1.0)
+
+SET(SRCS)
+SET(INC_DIRS ${NNFW_INCLUDE_DIR})
+
+add_subdirectory(depend)
+add_subdirectory(runtime)
+add_subdirectory(common)
+
+SET(INC_DIRS ${INC_DIRS} include)
+
+include_directories(${LIB_RUNTIME} PRIVATE ${INC_DIRS})
+
+add_library(${LIB_RUNTIME} SHARED ${SRCS})
+if(TARGET kernelacl)
+ target_compile_definitions(${LIB_RUNTIME} PRIVATE USE_NNFW_ACL_KERNELS)
+ target_link_libraries(${LIB_RUNTIME} kernelacl)
+endif(TARGET kernelacl)
+# we need the library name to be 'neuralnetworks' and this will do the trick
+set_target_properties(${LIB_RUNTIME} PROPERTIES OUTPUT_NAME neuralnetworks)
+
+install(TARGETS ${LIB_RUNTIME} DESTINATION lib)