summaryrefslogtreecommitdiff
path: root/runtimes/neurun/frontend/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/neurun/frontend/api/CMakeLists.txt')
-rw-r--r--runtimes/neurun/frontend/api/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/runtimes/neurun/frontend/api/CMakeLists.txt b/runtimes/neurun/frontend/api/CMakeLists.txt
new file mode 100644
index 000000000..10a33a85e
--- /dev/null
+++ b/runtimes/neurun/frontend/api/CMakeLists.txt
@@ -0,0 +1,12 @@
+file(GLOB_RECURSE API_SRC "*.cc")
+
+set(NEURUN_DEV nnfw-dev)
+add_library(${NEURUN_DEV} SHARED ${API_SRC})
+
+target_link_libraries(${NEURUN_DEV} PUBLIC nnfw-header)
+target_link_libraries(${NEURUN_DEV} PUBLIC neurun_core) # TODO Link PRIVATE neurun_core
+target_link_libraries(${NEURUN_DEV} PRIVATE jsoncpp tflite_loader ${LIB_PTHREAD})
+target_link_libraries(${NEURUN_DEV} PRIVATE nnfw_common)
+target_link_libraries(${NEURUN_DEV} PRIVATE nnfw_coverage)
+
+install(TARGETS ${NEURUN_DEV} DESTINATION lib)