summaryrefslogtreecommitdiff
path: root/runtimes/neurun/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/neurun/CMakeLists.txt')
-rw-r--r--runtimes/neurun/CMakeLists.txt24
1 files changed, 10 insertions, 14 deletions
diff --git a/runtimes/neurun/CMakeLists.txt b/runtimes/neurun/CMakeLists.txt
index 2cbd702b0..92547da2c 100644
--- a/runtimes/neurun/CMakeLists.txt
+++ b/runtimes/neurun/CMakeLists.txt
@@ -18,29 +18,23 @@ file(GLOB SOURCES_BACKEND "src/backend/*.cc")
file(GLOB_RECURSE SOURCES_INTERNAL "src/internal/*.cc")
file(GLOB_RECURSE SOURCES_GRAPH "src/graph/*.cc")
file(GLOB_RECURSE SOURCES_LINEAR "src/linear/*.cc")
-file(GLOB_RECURSE SOURCES_CODEGEN "src/codegen/*.cc")
+file(GLOB_RECURSE SOURCES_DUMPER "src/dumper/*.cc")
+file(GLOB_RECURSE SOURCES_COMPILER "src/compiler/*.cc")
file(GLOB_RECURSE SOURCES_VERIFIER "src/verifier/*.cc")
+file(GLOB_RECURSE SOURCES_UTIL "src/util/*.cc")
+file(GLOB_RECURSE SOURCES_MODEL "src/model/*.cc")
-set(SOURCES ${SOURCES} ${SOURCES_FRONTEND} ${SOURCES_BACKEND} ${SOURCES_INTERNAL} ${SOURCES_GRAPH} ${SOURCES_LINEAR} ${SOURCES_CODEGEN} ${SOURCES_VERIFIER})
-
-# NOTE For now ARMCompute is necessary
-# TODO Remove required package below(should be optional)
-nnfw_find_package(ARMCompute REQUIRED)
+set(SOURCES ${SOURCES} ${SOURCES_FRONTEND} ${SOURCES_BACKEND} ${SOURCES_INTERNAL} ${SOURCES_GRAPH} ${SOURCES_LINEAR} ${SOURCES_DUMPER} ${SOURCES_COMPILER} ${SOURCES_VERIFIER} ${SOURCES_UTIL} ${SOURCES_MODEL})
add_library(${LIB_NEURUN} SHARED ${SOURCES})
target_include_directories(${LIB_NEURUN} PUBLIC ${NNFW_INCLUDE_DIR})
target_include_directories(${LIB_NEURUN} PUBLIC ${NEURUN_INCLUDE_DIR})
target_include_directories(${LIB_NEURUN} PUBLIC ${CMAKE_SOURCE_DIR}/externals/tensorflow)
-target_link_libraries(${LIB_NEURUN} arm_compute)
target_link_libraries(${LIB_NEURUN} tensorflow-lite)
-target_link_libraries(${LIB_NEURUN} nnfw_util)
-target_link_libraries(${LIB_NEURUN} nnfw_support_nnapi)
-
-# TODO This should be optional
-target_link_libraries(${LIB_NEURUN} ${LIB_NEURUN_BACKEND_CPU})
-target_link_libraries(${LIB_NEURUN} ${LIB_NEURUN_BACKEND_ACL_CL})
+target_link_libraries(${LIB_NEURUN} nnfw_lib_misc)
+target_link_libraries(${LIB_NEURUN} nnfw_lib_cpp14)
-target_compile_options(${LIB_NEURUN} PRIVATE -Wall -Wextra -Werror)
+target_compile_options(${LIB_NEURUN} PRIVATE -Wall -Wextra -Werror -Wno-unused-parameter)
set_target_properties(${LIB_NEURUN} PROPERTIES OUTPUT_NAME neuralnetworks)
@@ -58,6 +52,8 @@ target_link_libraries(${TEST_NEURUN} ${LIB_NEURUN})
target_link_libraries(${TEST_NEURUN} gtest)
target_link_libraries(${TEST_NEURUN} gtest_main)
target_link_libraries(${TEST_NEURUN} ${LIB_PTHREAD})
+target_link_libraries(${TEST_NEURUN} ${LIB_NEURUN_BACKEND_CPU})
+target_link_libraries(${TEST_NEURUN} ${LIB_NEURUN_BACKEND_ACL_CL})
add_test(${TEST_NEURUN} ${TEST_NEURUN})
install(TARGETS ${TEST_NEURUN} DESTINATION unittest)