summaryrefslogtreecommitdiff
path: root/runtimes/libs/xprobe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/libs/xprobe/CMakeLists.txt')
-rw-r--r--runtimes/libs/xprobe/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/runtimes/libs/xprobe/CMakeLists.txt b/runtimes/libs/xprobe/CMakeLists.txt
new file mode 100644
index 000000000..006899b91
--- /dev/null
+++ b/runtimes/libs/xprobe/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_library(nnfw_lib_xprobe SHARED src/trace.cpp)
+target_include_directories(nnfw_lib_xprobe PUBLIC include)
+target_link_libraries(nnfw_lib_xprobe PUBLIC nnfw_lib_xdata)
+target_link_libraries(nnfw_lib_xprobe PUBLIC nnfw_lib_xray_pipe)
+target_link_libraries(nnfw_lib_xprobe PRIVATE nnfw_lib_cpp14)
+target_link_libraries(nnfw_lib_xprobe PRIVATE nnfw_common)
+target_link_libraries(nnfw_lib_xprobe PRIVATE nnfw_coverage)
+
+install(TARGETS nnfw_lib_xprobe LIBRARY DESTINATION lib)