summaryrefslogtreecommitdiff
path: root/runtimes/contrib/tflite_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/contrib/tflite_test/CMakeLists.txt')
-rw-r--r--runtimes/contrib/tflite_test/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/runtimes/contrib/tflite_test/CMakeLists.txt b/runtimes/contrib/tflite_test/CMakeLists.txt
new file mode 100644
index 000000000..760952a84
--- /dev/null
+++ b/runtimes/contrib/tflite_test/CMakeLists.txt
@@ -0,0 +1,16 @@
+if(NOT BUILD_TFLITE_TEST)
+ return()
+endif(NOT BUILD_TFLITE_TEST)
+
+nnfw_find_package(Tensorflow QUIET)
+
+if(NOT Tensorflow_FOUND)
+ return()
+endif(NOT Tensorflow_FOUND)
+
+list(APPEND SOURCES tflite_test.cpp)
+
+add_executable(tflite_test ${SOURCES})
+target_link_libraries(tflite_test PRIVATE nnfw_lib_tflite)
+target_link_libraries(tflite_test PRIVATE tensorflow-lite)
+target_link_libraries(tflite_test PRIVATE tensorflow-core)