summaryrefslogtreecommitdiff
path: root/runtimes/contrib/detection/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/contrib/detection/CMakeLists.txt')
-rw-r--r--runtimes/contrib/detection/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/runtimes/contrib/detection/CMakeLists.txt b/runtimes/contrib/detection/CMakeLists.txt
new file mode 100644
index 000000000..37d91b527
--- /dev/null
+++ b/runtimes/contrib/detection/CMakeLists.txt
@@ -0,0 +1,11 @@
+if(NOT BUILD_DETECTION_APP)
+ return()
+endif(NOT BUILD_DETECTION_APP)
+
+nnfw_find_package(Tensorflow REQUIRED)
+
+list(APPEND SOURCES detection.cpp)
+
+add_executable(detection ${SOURCES})
+target_link_libraries(detection nnfw_lib_misc)
+target_link_libraries(detection tensorflow-core)