summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt22
1 files changed, 18 insertions, 4 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 938752f23..3e1bdeb06 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -1,5 +1,19 @@
-if(BUILD_NN_RUNTIME)
- set(LIB_RUNTIME runtime)
- add_subdirectory(nn)
+set(BUILD_RUNTIME_TESTS OFF)
+
+if(BUILD_NEURUN)
+ set(LIB_NEURUN neurun)
+ add_subdirectory(neurun)
+endif(BUILD_NEURUN)
+
+if(BUILD_PURE_ARM_COMPUTE)
+ set(LIB_PUREACL_RUNTIME nnapi_pure_arm_compute)
+ add_subdirectory(pure_arm_compute)
+ set(BUILD_RUNTIME_TESTS ON)
+endif()
+
+if(BUILD_RUNTIME_TESTS)
add_subdirectory(tests)
-endif(BUILD_NN_RUNTIME)
+endif(BUILD_RUNTIME_TESTS)
+
+add_subdirectory(template)
+add_subdirectory(logging)