summaryrefslogtreecommitdiff
path: root/runtime/neurun/backend/acl_common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/neurun/backend/acl_common/CMakeLists.txt')
-rw-r--r--runtime/neurun/backend/acl_common/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/runtime/neurun/backend/acl_common/CMakeLists.txt b/runtime/neurun/backend/acl_common/CMakeLists.txt
deleted file mode 100644
index 32d01291f..000000000
--- a/runtime/neurun/backend/acl_common/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-# Unsupported architecture
-nnas_find_package(ARMCompute QUIET)
-if(NOT ARMCompute_FOUND)
- return()
-endif(NOT ARMCompute_FOUND)
-
-file(GLOB SOURCES "*.cc")
-
-add_library(${LIB_NEURUN_BACKEND_ACL_COMMON} STATIC ${SOURCES})
-
-target_include_directories(${LIB_NEURUN_BACKEND_ACL_COMMON} PUBLIC ${NEURUN_INCLUDE_DIR})
-target_include_directories(${LIB_NEURUN_BACKEND_ACL_COMMON} PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
-target_link_libraries(${LIB_NEURUN_BACKEND_ACL_COMMON} PUBLIC arm_compute arm_compute_ex)
-target_link_libraries(${LIB_NEURUN_BACKEND_ACL_COMMON} PUBLIC nnfw_lib_misc nnfw_lib_cpp14)
-target_link_libraries(${LIB_NEURUN_BACKEND_ACL_COMMON} PRIVATE nnfw_common)
-target_link_libraries(${LIB_NEURUN_BACKEND_ACL_COMMON} PRIVATE nnfw_coverage)
-
-set_target_properties(${LIB_NEURUN_BACKEND_ACL_COMMON} PROPERTIES POSITION_INDEPENDENT_CODE ON)
-set_target_properties(${LIB_NEURUN_BACKEND_ACL_COMMON} PROPERTIES OUTPUT_NAME backend_acl_common)