summaryrefslogtreecommitdiff
path: root/packaging/nnfw.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/nnfw.spec')
-rw-r--r--packaging/nnfw.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/packaging/nnfw.spec b/packaging/nnfw.spec
index 1f31af014..0af7a91cf 100644
--- a/packaging/nnfw.spec
+++ b/packaging/nnfw.spec
@@ -1,22 +1,20 @@
Name: nnfw
Summary: nnfw
-Version: 0.1
+Version: 0.2
Release: 1
Group: Development
-License: Apache-2.0 and MPL-2.0 and BSD-3-Clause
+License: Apache-2.0 and MIT
Source0: %{name}-%{version}.tar.gz
Source1: %{name}.manifest
+%ifarch arm armv7l aarch64
BuildRequires: cmake
+BuildRequires: python
BuildRequires: boost-devel
BuildRequires: gtest-devel
BuildRequires: tensorflow-lite-devel
-%ifarch aarch64
-BuildRequires: libarmcl-devel-aarch64
-%endif
-%ifarch %{arm}
BuildRequires: libarmcl-devel
%endif
@@ -50,9 +48,9 @@ NNFW test rpm. It does not depends on nnfw rpm since it contains nnfw runtime.
%{!?coverage_build: %define coverage_build 0}
%if %{coverage_build} == 1
-%define build_options COVERAGE_BUILD=1 OBS_BUILD=1 BUILD_TYPE=Debug TARGET_ARCH=%{target_arch} TARGET_OS=tizen
+%define build_options COVERAGE_BUILD=1 OBS_BUILD=1 BUILD_TYPE=Debug TARGET_ARCH=%{target_arch} TARGET_OS=tizen UPDATE_MODULE=0
%else
-%define build_options OBS_BUILD=1 BUILD_TYPE=%{build_type} INSTALL_PATH=%{buildroot}%{install_prefix} TARGET_ARCH=%{target_arch} TARGET_OS=tizen
+%define build_options OBS_BUILD=1 BUILD_TYPE=%{build_type} INSTALL_PATH=%{buildroot}%{install_prefix} TARGET_ARCH=%{target_arch} TARGET_OS=tizen UPDATE_MODULE=0
%endif
%prep
@@ -60,9 +58,12 @@ NNFW test rpm. It does not depends on nnfw rpm since it contains nnfw runtime.
cp %{SOURCE1} .
%build
+%ifarch arm armv7l aarch64
%{build_options} make %{?jobs:-j%jobs}
+%endif
%install
+%ifarch arm armv7l aarch64
%{build_options} make install
%if %{coverage_build} == 0
@@ -71,7 +72,8 @@ cp %{SOURCE1} .
mkdir -p %{buildroot}%{test_install_prefix}/Product/out
mv %{buildroot}%{install_prefix}/unittest %{buildroot}%{test_install_prefix}/Product/out
mv %{buildroot}%{install_prefix}/bin %{buildroot}%{test_install_prefix}/Product/out
-mv %{buildroot}%{install_prefix}/lib %{buildroot}%{test_install_prefix}/Product/out
+cp -rf %{buildroot}%{install_prefix}/lib %{buildroot}%{test_install_prefix}/Product/out
+rm -rf %{buildroot}%{install_prefix}/lib/pureacl
## install tests
cp -rf ./tests %{buildroot}%{test_install_prefix}/.
## install tools
@@ -84,6 +86,7 @@ cp -rf Product/out/coverage-suite.tar.gz %{buildroot}%{test_install_prefix}/.
tar -zxf %{buildroot}%{test_install_prefix}/coverage-suite.tar.gz -C %{buildroot}%{test_install_prefix}
rm -rf %{buildroot}%{test_install_prefix}/coverage-suite.tar.gz
%endif
+%endif
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
@@ -91,14 +94,18 @@ rm -rf %{buildroot}%{test_install_prefix}/coverage-suite.tar.gz
%files
%manifest %{name}.manifest
%defattr(-,root,root,-)
+%ifarch arm armv7l aarch64
%{install_prefix}/lib/*
%exclude %{install_prefix}/bin/*
%exclude %{install_prefix}/unittest/*
+%endif
%files test
%manifest %{name}.manifest
%defattr(-,root,root,-)
+%ifarch arm armv7l aarch64
%{test_install_prefix}/*
+%endif
%changelog
* Thu Mar 15 2018 Chunseok Lee <chunseok.lee@samsung.com>