summaryrefslogtreecommitdiff
path: root/libs/kernel/acl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/kernel/acl/CMakeLists.txt')
-rw-r--r--libs/kernel/acl/CMakeLists.txt94
1 files changed, 0 insertions, 94 deletions
diff --git a/libs/kernel/acl/CMakeLists.txt b/libs/kernel/acl/CMakeLists.txt
deleted file mode 100644
index 8f0486e56..000000000
--- a/libs/kernel/acl/CMakeLists.txt
+++ /dev/null
@@ -1,94 +0,0 @@
-set(LIB_KERNELACL kernelacl)
-set(LIB_KERNELACL_TEST kernelacl_test)
-
-# TODO remove this when default goes to c++14
-if(CMAKE_VERSION VERSION_LESS 3.1.0)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
-else(CMAKE_VERSION VERSION_LESS 3.1.0)
- set(CMAKE_CXX_STANDARD 14)
-endif(CMAKE_VERSION VERSION_LESS 3.1.0)
-
-# runtime information
-set(PATH_RUNTIME_NN ${CMAKE_SOURCE_DIR}/runtimes/nn)
-SET(RUNTIME_INCLUDES ${PATH_RUNTIME_NN}/common/include
- ${PATH_RUNTIME_NN}/runtime/include
- ${PATH_RUNTIME_NN}/depend/hal/include
- ${PATH_RUNTIME_NN}/depend/libhidl/base/include
- ${PATH_RUNTIME_NN}/depend/libcutils/include
- ${PATH_RUNTIME_NN}/depend/libutils/include
- ${PATH_RUNTIME_NN}/depend/android-base/include
- )
-
-# common
-link_directories(${CMAKE_INSTALL_PREFIX}/lib)
-
-# kernel library
-set(KERNELACL_SRCS "src/Init_acl.cpp"
- "src/IO_accessor.cpp"
- "src/shape.cpp"
- "src/support.cpp"
- "src/cl/Conv2D.cpp"
- "src/cl/DepthwiseConv2D.cpp"
- "src/cl/FullyConnected.cpp"
- "src/cl/Pooling.cpp"
- "src/cl/Reshape.cpp"
- "src/cl/Softmax.cpp"
- "src/cl/Concatenation.cpp"
- "src/neon/Conv2D.cpp"
- "src/neon/DepthwiseConv2D.cpp"
- "src/neon/FullyConnected.cpp"
- "src/neon/Pooling.cpp"
- "src/neon/Softmax.cpp"
- "src/neon/Reshape.cpp"
- "src/neon/Concatenation.cpp"
- )
-
-add_library(${LIB_KERNELACL} SHARED ${KERNELACL_SRCS})
-target_include_directories(${LIB_KERNELACL} PUBLIC
- ${NNFW_INCLUDE_DIR}
- ${RUNTIME_INCLUDES}
- ${NNFW_ACL_INCLUDES}
- ${CMAKE_SOURCE_DIR}/include
- )
-target_link_libraries(${LIB_KERNELACL} nnfw_support_nnapi)
-if (${TARGET_OS} STREQUAL "tizen")
- target_link_libraries(${LIB_KERNELACL} nnfw_util ${NNFW_ACL_LIBS} OpenCL)
-else()
- target_link_libraries(${LIB_KERNELACL} nnfw_util ${NNFW_ACL_LIBS})
-endif()
-install(TARGETS ${LIB_KERNELACL} DESTINATION lib)
-
-# kernel test executable
-set(KERNELACL_TEST_SRCS "src/util.cpp"
- "src/gtest_env.cpp"
- "src/cl/Conv2D.test.cpp"
- "src/cl/DepthwiseConv2D.test.cpp"
- "src/cl/FullyConnected.test.cpp"
- "src/cl/Pooling.test.cpp"
- "src/cl/Reshape.test.cpp"
- "src/cl/Softmax.test.cpp"
- "src/cl/Concatenation.test.cpp"
- "src/neon/Conv2D.test.cpp"
- "src/neon/DepthwiseConv2D.test.cpp"
- "src/neon/FullyConnected.test.cpp"
- "src/neon/Pooling.test.cpp"
- "src/neon/Softmax.test.cpp"
- "src/neon/Reshape.test.cpp"
- "src/neon/Concatenation.test.cpp"
- )
-
-add_executable(${LIB_KERNELACL_TEST} ${KERNELACL_TEST_SRCS})
-target_include_directories(${LIB_KERNELACL_TEST} PUBLIC
- ${NNFW_INCLUDE_DIR}
- ${RUNTIME_INCLUDES}
- ${NNFW_ACL_INCLUDES}
- )
-if (NOT ${TARGET_OS} STREQUAL "tizen")
- add_dependencies(${LIB_KERNELACL_TEST} googletest)
-endif()
-target_link_libraries(${LIB_KERNELACL_TEST}
- ${LIB_KERNELACL}
- nnfw_util ${NNFW_ACL_LIBS}
- ${NNFW_GTEST_LIBS}
- )
-install(TARGETS ${LIB_KERNELACL_TEST} DESTINATION unittest)