summaryrefslogtreecommitdiff
path: root/infra/nnfw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'infra/nnfw/CMakeLists.txt')
-rw-r--r--infra/nnfw/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/infra/nnfw/CMakeLists.txt b/infra/nnfw/CMakeLists.txt
index 6b5c465d2..437573541 100644
--- a/infra/nnfw/CMakeLists.txt
+++ b/infra/nnfw/CMakeLists.txt
@@ -48,7 +48,7 @@ macro(nnas_find_package PREFIX)
)
endmacro(nnas_find_package)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_EXTENSIONS OFF)
# This feature works with CMake 3.5.2 or later. However, using previous versions does not produce
@@ -92,6 +92,12 @@ if(ENABLE_STRICT_BUILD)
target_compile_options(nnfw_common INTERFACE -Werror -Wall -Wextra)
endif(ENABLE_STRICT_BUILD)
+macro(nnfw_strict_build TARGET)
+ if(ENABLE_STRICT_BUILD)
+ target_compile_options(${TARGET} PRIVATE -Werror -Wall -Wextra)
+ endif(ENABLE_STRICT_BUILD)
+endmacro(nnfw_strict_build)
+
# TODO Replace using default build option setting in cmake/buildtool/config/config_linux.cmake
# to link nnfw_coverage on each module which want to check coverage
add_library(nnfw_coverage INTERFACE)