summaryrefslogtreecommitdiff
path: root/infra/nnfw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'infra/nnfw/CMakeLists.txt')
-rw-r--r--infra/nnfw/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/infra/nnfw/CMakeLists.txt b/infra/nnfw/CMakeLists.txt
index 1a93d032d..868381a70 100644
--- a/infra/nnfw/CMakeLists.txt
+++ b/infra/nnfw/CMakeLists.txt
@@ -57,19 +57,12 @@ include("cmake/CfgOptionFlags.cmake")
nnfw_find_package(GTest QUIET)
-if(NOT DEFINED ENABLE_TEST)
- # Enable test by default
- set(ENABLE_TEST ${GTest_FOUND})
-endif(NOT DEFINED ENABLE_TEST)
+option(ENABLE_TEST "Build Tests using Google Test" ${GTest_FOUND})
if(${ENABLE_TEST} AND NOT ${GTest_FOUND})
message(FATAL_ERROR "Google Test is required to enable test")
endif(${ENABLE_TEST} AND NOT ${GTest_FOUND})
-if(NOT DEFINED ENABLE_COVERAGE)
- set(ENABLE_COVERAGE FALSE)
-endif(NOT DEFINED ENABLE_COVERAGE)
-
if(${ENABLE_COVERAGE} AND NOT ${ENABLE_TEST})
message(FATAL_ERROR "Test should be enabled to measure test coverage")
endif(${ENABLE_COVERAGE} AND NOT ${ENABLE_TEST})