summaryrefslogtreecommitdiff
path: root/contrib/opencl_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/opencl_test/CMakeLists.txt')
-rw-r--r--contrib/opencl_test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/contrib/opencl_test/CMakeLists.txt b/contrib/opencl_test/CMakeLists.txt
new file mode 100644
index 000000000..45b07e181
--- /dev/null
+++ b/contrib/opencl_test/CMakeLists.txt
@@ -0,0 +1,11 @@
+if(NOT ${TARGET_ARCH_BASE} STREQUAL "arm")
+ return()
+endif(NOT ${TARGET_ARCH_BASE} STREQUAL "arm")
+
+list(APPEND OPENCL_INFO_SOURCE "src/opencl_test.cc")
+
+add_executable(opencl_test ${OPENCL_INFO_SOURCE})
+target_include_directories(opencl_test PUBLIC ${CMAKE_SOURCE_DIR}/externals/acl)
+target_include_directories(opencl_test PUBLIC ${CMAKE_SOURCE_DIR}/externals/acl/include)
+target_link_libraries(opencl_test arm_compute)
+