summaryrefslogtreecommitdiff
path: root/compute/cker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compute/cker/CMakeLists.txt')
-rw-r--r--compute/cker/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/compute/cker/CMakeLists.txt b/compute/cker/CMakeLists.txt
new file mode 100644
index 000000000..9ddec350b
--- /dev/null
+++ b/compute/cker/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_library(nnfw_lib_cker INTERFACE)
+
+nnfw_find_package(Eigen QUIET)
+option(BUILD_CKER_OPTIMIZE "Build optimize cker library" ON)
+
+if(Eigen_FOUND AND BUILD_CKER_OPTIMIZE)
+ target_link_libraries(nnfw_lib_cker INTERFACE eigen)
+ target_compile_definitions(nnfw_lib_cker INTERFACE CKER_OPTIMIZED_EIGEN)
+endif(Eigen_FOUND AND BUILD_CKER_OPTIMIZE)
+
+target_include_directories(nnfw_lib_cker INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}/include)