summaryrefslogtreecommitdiff
path: root/compiler/tflchef/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/tflchef/core/CMakeLists.txt')
-rw-r--r--compiler/tflchef/core/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/compiler/tflchef/core/CMakeLists.txt b/compiler/tflchef/core/CMakeLists.txt
new file mode 100644
index 000000000..6a6282027
--- /dev/null
+++ b/compiler/tflchef/core/CMakeLists.txt
@@ -0,0 +1,7 @@
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_library(tflchef_core STATIC ${SOURCES})
+target_include_directories(tflchef_core PUBLIC include)
+target_include_directories(tflchef_core PRIVATE src)
+target_link_libraries(tflchef_core tflchef_proto)
+target_link_libraries(tflchef_core mio_tflite)